Engine Knocking, Rough Idle, Misfire? Video | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

Engine Knocking, Rough Idle, Misfire? Video

keepthecoffeeon

New Member
Joined
September 21, 2017
Messages
3
Reaction score
0
Location
Phoenix
City, State
Phoenix, AZ
Year, Model & Trim Level
1999 Ford Explorer Sport
Alrighty a little background.

I recently put the following new parts on my 1999 4.0 OHV Explorer

130 Amp Alternator
Upper Intake Manifold
Fuel Injectors
Fuel Rail Gasket
Replaced the EGR Tube O-Ring


The first time I put everything back together my truck ran with no knocking at all. The issue was one of the O-rings on a fuel injector did not seat correctly into the fuel rail and subsequently was leaking fuel so I had to take everything off to fix it. :sawzall:

Second time around I got everything seated correctly, all hoses and connections, etc. And now I have a terrible knocking noise in the engine and I for the life of me cannot figure out what is wrong.

I've tripled checked my firing order for the spark plugs from the cylinders to the coil pack. :dunno:

I've noticed when I disconnect the vacuum hose from the EGR valve the vehicle runs smoother for about 5-10 seconds, the knocking subsides somewhat, when I reconnect it knocks more rapidly.

Fluids are all normal.

The EGR tube gets extremely hot even if the car is only on for 30-45 seconds... I posted a video of the sound to maybe give you guys a better idea.

I'm also not sure if its because the alternator is new but it smells awful :wtf:

 






keepthecoffeeon

New Member
Joined
September 21, 2017
Messages
3
Reaction score
0
Location
Phoenix
City, State
Phoenix, AZ
Year, Model & Trim Level
1999 Ford Explorer Sport
Any ideas fellas? Still haven't been able to figure anything out. I'm taking her apart Thursday to see if I can find anything.
 






Top