• Register Today It's free! This box and some ads will disappear once registered!

Engine Miss/Bucking only in Neutral/Park @3000 RPM or higher

jedbmw

New Member
Joined
August 22, 2009
Messages
1
Reaction score
0
City, State
Medford, NJ
Year, Model & Trim Level
2002
Thanks in advance

2002 Ford Explorer Sport XLT
6 Cylinder – 102,000 miles

Engine runs fine/normal in drive under load. Stomp tested vehicle up to 5000 RPM no problems, engine performs normal.

When the engine is running in neutral/park and I stomp on the gas, at about 3000 RPM the engine appears to be starved for fuel, RPM jumps/cycles between 2500 – 3000 RPM.

Cycling happens when I slowly raise the RPM in park/neutral. I notice a little engine roughness/vibration when doing this gets worse at higher RPM

I have no `check engine` indication.


- Installed a new fuel filter and new Spark Plugs so far.

John
 




Scotty J.

Packin
Joined
June 21, 2009
Messages
1,265
Reaction score
3
City, State
Little Rock, Ar
Year, Model & Trim Level
'02 Ford Ranger XLT
Sounds like a Rev Limiter, I have found that my Ranger 4.0 SOHC does the same thing. Mine is automatic and has a speed limiter at 90mph as well.
 




SESCOKID

New Member
Joined
August 23, 2009
Messages
6
Reaction score
0
City, State
LAKELAND, FL
Year, Model & Trim Level
2003 SPORT TRAC
I had the same problem and looking through the messages here i found someone had a crack in teh small elbow hose for the pcv valve near the intake and looked - sure emough there it was !! Look under the intake cover with the engine size logo on it
 




Top