• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Explorer A-Pillar Rattle/Noise

CajunFordEx

Active Member
Joined
June 11, 2012
Messages
241
Reaction score
1
City, State
Cajun Country La
Year, Model & Trim Level
2017 Kia Sorento LX
Callsign
KC5OAO
I have a rattling sound from my right passenger side (not sure from rear or front) and the rattling sound from the windsheild. Been to the dealer and they claim that they can reproduce it and they blame it on the cream tube that have in the door which could be causing the sound (which obviously isn;t). Can you please run my VIN and check if i mine has any of these issues? VIN xxxxxxxxxxxxxxxxxxxx.

I can be reached at ????????

I strongly advise you to edit your post and remove your personal info. It's for your protection from idiots and bots.
It would be best to send Crystal a Private Message. She will answer your private messages;)
 
Join the Elite Explorers for $20.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.


FordService

Official Ford Rep
Joined
October 25, 2010
Messages
5,281
Reaction score
11
City, State
Dearborn, MI
Year, Model & Trim Level
2014
I have a rattling sound from my right passenger side (not sure from rear or front) and the rattling sound from the windsheild. Been to the dealer and they claim that they can reproduce it and they blame it on the cream tube that have in the door which could be causing the sound (which obviously isn;t)...
Hi grinu,

Take a peek at your inbox; I've responded to your PM. Also, I want to reiterate the point that CajunFordEx makes below: I recommend removing your personal information from your public post.

I strongly advise you to edit your post and remove your personal info. It's for your protection from idiots and bots.
It would be best to send Crystal a Private Message. She will answer your private messages;)
Thanks for the shout-out and the good advice, CajunFordEx!

Crystal
 

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,458
Reaction score
1,382
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
I have a rattling sound from my right passenger side (not sure from rear or front) and the rattling sound from the windsheild. Been to the dealer and they claim that they can reproduce it and they blame it on the cream tube that have in the door which could be causing the sound (which obviously isn;t). Can you please run my VIN and check if i mine has any of these issues?
Welcome to the Forum grinu.:wavey:
It isn't possible to know if you have any issues simply by running the VIN. That will only tell you if certain TSB's have been drawn up to address any identified problems that MAY occur. It doesn't neccessarily mean the problem will happen.
I have a 2011 Limited and have only had one of the many TSB's carried out on mine. That was for the random windshield wipe.
I ran your VIN and see that you have a 2011 XLT AWD. It would be very useful for members responding to any questions or concerns you may have if you added that information to your vehicle specs show that it will show in the left margin. Some answers apply only to certain models.

Peter
 

LVTX2011

New Member
Joined
January 19, 2013
Messages
4
Reaction score
0
City, State
Texas
Year, Model & Trim Level
2017 Explorer XLT
I would begin with taking it to the dealer and have them perform the TSB that exists for this problem.

TSB 12-1-11 A-PILLAR TRIM RATTLE AND/OR BUZZ - BUILT ON OR BEFORE 11/21/2011.

It would also be helpful for the members here if you showed which model and year Explorer you have in the left hand margin. It would help in answering any future issues you may have since some answers are model specific.
Happy New Year!

Peter
Peter,
Great information. I have had this issue with my 2011 since shortly after purchase in Apr 2011 but have been reluctant to have the dealer check it. Only appears at speeds around 60+ and with certain wind conditions. My fear is more issues created by fixing that living with some noise. You appear to be very active on this forum, can you point me to any data on the success rate of real correction?
Thanks
 

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,458
Reaction score
1,382
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
Peter,
Great information. I have had this issue with my 2011 since shortly after purchase in Apr 2011 but have been reluctant to have the dealer check it. Only appears at speeds around 60+ and with certain wind conditions. My fear is more issues created by fixing that living with some noise. You appear to be very active on this forum, can you point me to any data on the success rate of real correction?
Thanks
Unfortunately the only data/stats I keep track of are those for the players on the hockey team I coach. ;)
In most cases, but not all, the dealer wants to be able to re-create the noise. It sounds like this may be difficult in your case because it only happens sometimes under certain conditions.
Initial repairs were not that successful from the posts I have read. Part of the problem was that the technicians were not replacing the plastic clips holding the covers on. In some cases these clips broke off when the pillar cover was removed. There were a few instances where the covers actually blew off on the highway. I believe that since that time repairs have had a more successful rate and that new clips are now part of the repair package.
I know this isn't too helpful but I doubt that any data is being kept on these or any repairs.
If you know which pillar is creating the problem you could always visit you dealer and see what they have to say.

Peter
 

downhome

New Member
Joined
December 2, 2012
Messages
5
Reaction score
0
City, State
Northern KY
Year, Model & Trim Level
2011 Explorer Limited
I have the same wind rattle out of the passenger A pillar. I will be taking my Explorer in this week and for some issues with the My Ford Touch.
 
Last edited:

CajunFordEx

Active Member
Joined
June 11, 2012
Messages
241
Reaction score
1
City, State
Cajun Country La
Year, Model & Trim Level
2017 Kia Sorento LX
Callsign
KC5OAO
I have had this issue with my 2011 since shortly after purchase in Apr 2011 but have been reluctant to have the dealer check it. Only appears at speeds around 60+ and with certain wind conditions. My fear is more issues created by fixing that living with some noise.
The only repair I have had an my Ex is the "A pillar" repair. This was done in July of 2011 if I remember correctly. I got my Ex in May 2011. This was before there was a TSB on the pillar I believe. My dealer had a tech come ride with me and he heard the noise before I did. They pinpointed it to the passenger side A pillar,ordered parts, called me 3 days later and I went in and got it fixed while shooting the breeze with my salesman. No noise since.
What bothers me now is that my windshield is cracked and will most likely have to be replaced before it can pass state inspection in May. The last time I had a windshield replaced was on a 1992 Ranger and that was a nightmare getting it to stop leaking. I do not want that to happen with my Ex.

My advice to you is to get it fixed under warranty by a reputable dealer unless the noise really does not bother you at all.
 

jdahunt

New Member
Joined
December 12, 2012
Messages
3
Reaction score
0
City, State
Illinois
Year, Model & Trim Level
2011 Ford Explorer
I have the same wind rattle out of the passenger A pillar. I will be taking my Explorer in this week and for some issues with the My Ford Touch.
My dealer fixed my pillar rattle, told me it was a common issue and they replace the parts.....no rattle since.
 

tryan1977

New Member
Joined
October 6, 2011
Messages
47
Reaction score
0
Dealer still says there is nothing wrong with the windshield. Last time i took it in they said they took it for a test drive and couldnt hear it. There is a TSB for this but it doesnt fix the problem.
 

downhome

New Member
Joined
December 2, 2012
Messages
5
Reaction score
0
City, State
Northern KY
Year, Model & Trim Level
2011 Explorer Limited
Well that was a BIG letdown. Took my Explorer into the dealer Wed morning for the A-pillar rattle, tinny roof noise in the rain, and the radio not turning on until you insert a cd. I also asked for the oil change and they talked me into rotating the tires. Wed about 5pm they called and said they were waiting for word back from Ford about the radio issue and could they keep it overnight. I said ok. Thurs around 4pm I still hadn't heard from them so I called. They still hadn't done anything except the oil change and rotation. Guess who won't be going back there again.
 

foxtemple

Active Member
Joined
May 17, 2012
Messages
235
Reaction score
0
City, State
Philadelphia, PA
Year, Model & Trim Level
2011 Ford Explorer
Well that was a BIG letdown. Took my Explorer into the dealer Wed morning for the A-pillar rattle, tinny roof noise in the rain, and the radio not turning on until you insert a cd. I also asked for the oil change and they talked me into rotating the tires. Wed about 5pm they called and said they were waiting for word back from Ford about the radio issue and could they keep it overnight. I said ok. Thurs around 4pm I still hadn't heard from them so I called. They still hadn't done anything except the oil change and rotation. Guess who won't be going back there again.
My dealer jumps right on work that I pay for but is hesitant and slow as molasses when it comes to warranty work. Seems like a ford dealer trait.
 

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,458
Reaction score
1,382
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
My dealer jumps right on work that I pay for but is hesitant and slow as molasses when it comes to warranty work. Seems like a ford dealer trait.
That could be due to them having to get the go-ahead from Ford to do the warranty work. I've read a few posts where that was the delay. As for the TSB I had done (random windshiled wipe), the dealer just looked it up in his computer and did the work.

Peter
 

downhome

New Member
Joined
December 2, 2012
Messages
5
Reaction score
0
City, State
Northern KY
Year, Model & Trim Level
2011 Explorer Limited
The A-pillar and the tinny roof noise have TSB's so there no reason they could not be done. They are one of my customers, I work on their shop equipment. Imagine the response I would get if I took their equipment down for two days and still didn't finish the job.
 
Last edited:

Daniel1402

New Member
Joined
December 7, 2012
Messages
2
Reaction score
0
City, State
Ottawa, Ontario
Year, Model & Trim Level
2012 EX Limited AWD
I took my 2012 Ex Limited last week and my dealer changed both applique on the A pillars. They decided on doing this first and see the result before touching the cowl. As far as I know, the TSB covers the applique replacement only so this is what they did. They told me to come back if I have the same rattling noise in the future, which would mean that the cowl IS the culprit!

I drive a $55,000 vehicle and I expected my dealer to BELIEVE me when I said that I had a very noisy rattling noise around the windshield on the highway. They did believe me and performed the TSB 12-1-11. There is no point in test driving the vehicle for a problem of this nature. It is a waste of time for everybody when the TSB takes only 0.3 hours to perform and the parts are not very expensive!

Now I need to drive on the highway a few times and see if the rattling noise is gone or not...

Daniel
 

JoeinCharlotte

New Member
Joined
February 7, 2012
Messages
3
Reaction score
0
City, State
Charlotte, NC
Year, Model & Trim Level
2011 Ford Explorer XLT
I took my 2011 in and the dealer said the A Pillar had already been fixed even though there was still rattling. Well I asked them to do it again since I bought the vehicle used, so they did. It still rattles. Mostly at highway speeds when there is a crosswind. It's not bad all the time, but really annoying on long trips. Any tips on how to fix this yourself since the dealer's fix doesn't seem to be working?
 

peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
26,458
Reaction score
1,382
City, State
Ottawa, Ontario area
Year, Model & Trim Level
2020 Aviator Reserve II
Callsign
VE3
I took my 2011 in and the dealer said the A Pillar had already been fixed even though there was still rattling. Well I asked them to do it again since I bought the vehicle used, so they did. It still rattles. Mostly at highway speeds when there is a crosswind. It's not bad all the time, but really annoying on long trips. Any tips on how to fix this yourself since the dealer's fix doesn't seem to be working?
Welcome to the Forum JoeinCharlotte. :wavey:
Are you sure it is the 'A' pillar causing the noise? A few other members who had a noise found that it was the plastic cowl that runs along the bottom of the windshield that caused the problem. I guess one way to check if it is the pillars would be to tape any open areas where the wind could get in and cause a problem and then road test it again. If the issue is gone then it looks like it is the pillars, again.

Peter
 

Youngr4

New Member
Joined
March 2, 2011
Messages
15
Reaction score
0
I have the same problem except mine hasn't fallen off yet, I take it to the dealer and they keep gluing it back on. The last time I took it into the dealer they charged me $200 to get it glued back on because it wasn't under warranty anymore. I will not be taking it back to the dealer to get it fixed for that much money. Oh and the first time I noticed the molding coming up was when I was washing the car and the sharp tip of the molding cut my finger.
 

cnsheets

Active Member
Joined
September 7, 2011
Messages
949
Reaction score
0
Year, Model & Trim Level
2011 Explemoner
Glued? It should not be glued. They need to replace the clips and install it properly.
 
Join the Elite Explorers for $20.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.


jeff59rt1

Active Member
Joined
January 13, 2011
Messages
100
Reaction score
0
City, State
Pa
Year, Model & Trim Level
2014 Explorer XLT
I'd give them a bill for 400$ for glueing it on!....when done right the new ones don't come off or buzzzzzzzzzzzz.
 

Top