Explorer V8 engine misfire | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Explorer V8 engine misfire

bojans

Well-Known Member
Joined
April 24, 2006
Messages
270
Reaction score
0
City, State
McHenry, Il
Year, Model & Trim Level
2006 Explorer Limited
My 06 was running very rough this morning, after about 1/2 mile the engine light came on and then began flashing. I drove back home and just before I pulled into drive way the light stopped flashing and the car was running fine. Per the owners manual the flashing engine light indicates an engine misfire. Anyone else have this issue before and if so what was the root of the problem? I will plug it into a scan tool tonight and pull the code.
 
<



dothedeww

Well-Known Member
Joined
December 23, 2008
Messages
485
Reaction score
2
City, State
West Friendship, MD
Year, Model & Trim Level
2006 Explorer XLT
let us know what the code is then that'll tell a lot. Ive had so many different things cause misfire..hopefully the code will help.

If not..pull the plugs...see what they look like. That was the source of the misfire on my ex.
 
<



bojans

Well-Known Member
Joined
April 24, 2006
Messages
270
Reaction score
0
City, State
McHenry, Il
Year, Model & Trim Level
2006 Explorer Limited
code P0306 - misfire on #6. Erased code, has not re thrown it yet. Planning on replacing all of the plugs (60k, figure better to pull the disimilar metals apart now rather than wait since I had an issue). Hope the problem doesn't come back.
 
<



dothedeww

Well-Known Member
Joined
December 23, 2008
Messages
485
Reaction score
2
City, State
West Friendship, MD
Year, Model & Trim Level
2006 Explorer XLT
so yeah..i would change the plugs. Mine were shot at 50k..all red and purple on the ends..let me know what yours look like.
 
<



Top