Factory Amp and HU ?'s | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Factory Amp and HU ?'s

Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,863
Reaction score
2,381
Year, Model & Trim Level
1998 Mountaineer AWD
I have a Panasonic HU in my X that is running off of the factory amp. When I bought my wiring and the guy found out it was for an Explorer he said I would eventually burn out the factory amp. My one passanger side front speaker is starting to fuzz occasionally. Plus I think the SQ of the factory amp prob. isn;t as good as my HU, which sounded pretty good in my old car. Anyone ever have the factory amp burn up? And should I bypass the amp, or go through the trouble of running all new wires:(
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




kardinal

Well-Known Member
Joined
November 10, 2001
Messages
101
Reaction score
0
City, State
Lawrenceville, GA
Year, Model & Trim Level
97 XLT
thats what i did with mine, i just bypassed the factory setup. however i love doing stereos so it was fun for me. i like stringing wire throughout the car.

to answer the question though, the explorer has a retarded factory stereo setup using their own amp. so id' just bypass the thing. are you still using factory speakers too? if so one of those may be going bad, ford doesnt really use quality stereo compnents :D :D trust me i know, i blew up 3 of the 4 door speakers in my x before i realized that, hey! i need to get some good speakers! hehehe.
 
<



mahieber

Elite Explorer
Joined
December 4, 2000
Messages
541
Reaction score
1
City, State
League City, TX
Year, Model & Trim Level
'92 XLT 4x4
Foam rot of the speakers is probably the case for one speaker going out. You can buy an amp bypass kit and run your HU's speaker outs to through the factory wiring.

If he told you it would burn out the amp, it could only be from running speaker level (amplified) signals to the amp. The factory amp expects pre-amp level outputs.

If you are running the amplified signals to your factory amp, just by the $10 amp bypass kit which is two plugs on 10" of wires and you should be okay.
 
<



leenjen

Explorer Addict
Joined
May 6, 2001
Messages
5,398
Reaction score
0
City, State
in the poconos, PA
Year, Model & Trim Level
2001 sport
call up crutchfield and get a bypass harness for about $15
 
<



Mbrooks420

High Voltage.
Elite Explorer
Joined
February 2, 2002
Messages
11,863
Reaction score
2,381
Year, Model & Trim Level
1998 Mountaineer AWD
I have Fosgate 6x8's and I really don't think that they are blown. I think tomorrow I'll pull the panel off and just splice the harnesses together. I'll prob just get another amp and mount it behind the panel.
 
<



Top