• Register Today It's free! This box and some ads will disappear once registered!

Factory Radio Self Test

ExplorerDMB

Moderator/Technician
Moderator Emeritus
Joined
January 26, 2004
Messages
6,162
Reaction score
8
City, State
Mechanicsville, Virginia
Year, Model & Trim Level
2004 Acura TL
I have tested this only on a '98 Ford F-150 and my '00 Explorer, and it has worked both times.

There is a factory "self-test" for the radio that starts by having the radio on, and having it on FM (Do not have it on CD, it will not work). Once you have it on FM, push and hold #3 and #6 buttons and the radio will run a self test at which it'll send the sound to the RF, LF, LR, RR speaker while displaying which speaker it is at on the display.

So why is this useful? Say you have no sound in one speaker - now all you have to do is test for current/voltage down there when it goes into self test mode and if you get voltage, your speaker is bad. Otherwise you have either a wire issue or a head unit issue. But if you have a good ground and you aren't getting power/current, then you should trace the power wire to the head unit (if you can). Hope this helps someone out.

The only thing I ask from you is that you try on your Explorer and then post back on here your year, model, and possibly radio choice (premium or not). Thanks

-Drew
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.








fobrnno

Well-Known Member
Joined
July 15, 2001
Messages
110
Reaction score
0
City, State
toronto, canada
Year, Model & Trim Level
98 xlt, 94xlt
i try it on mine and the test worked its a 98 explorer xlt with am/fm/cd.
i don't no if it a premium or not? how can you tell?
 




Joined
April 13, 2003
Messages
695
Reaction score
0
Worked.

'98 XLT - single CD w/o subwoofer

I think I have the '97 and earlier style radio, since I have a factory external amp in the pass. side rear quarter panel. With an 8/97 build date, I also have a '97 steering wheel and a few other parts.
 




Doubt Incarnate

Well-Known Member
Joined
May 9, 2005
Messages
531
Reaction score
0
City, State
"Franktucky", Ohio
Year, Model & Trim Level
'99 Eddie Bauer
works on the 99 am/fm/cd/cassette w/changer/subwoofer
 




ExplorerDMB

Moderator/Technician
Moderator Emeritus
Joined
January 26, 2004
Messages
6,162
Reaction score
8
City, State
Mechanicsville, Virginia
Year, Model & Trim Level
2004 Acura TL
works on 01 Mercury Sable
 








RGRyRy

Member
Joined
October 20, 2004
Messages
12
Reaction score
0
City, State
Los Angeles, CA
Year, Model & Trim Level
'98 EB
it worked on my 98 eddie bauer
 








mad_dog97

Member
Joined
April 17, 2006
Messages
47
Reaction score
0
City, State
Richmond, VA
Year, Model & Trim Level
'04 EB
Worked on my '04 Eddie Bauer - (Audiophile stereo)
 




Supersnizzz

Member
Joined
December 14, 2004
Messages
24
Reaction score
0
City, State
School- Socorro, NM Home-Rialto, CA
Year, Model & Trim Level
'96 XLT
It worked in my 96 (JBL system)
 




boxer1

New Member
Joined
July 24, 2006
Messages
4
Reaction score
0
City, State
Summerville, SC
Year, Model & Trim Level
1999 Explorer Limited
ExplorerDMB said:
I have tested this only on a '98 Ford F-150 and my '00 Explorer, and it has worked both times.

There is a factory "self-test" for the radio that starts by having the radio on, and having it on FM (Do not have it on CD, it will not work). Once you have it on FM, push and hold #3 and #6 buttons and the radio will run a self test at which it'll send the sound to the RF, LF, LR, RR speaker while displaying which speaker it is at on the display.

So why is this useful? Say you have no sound in one speaker - now all you have to do is test for current/voltage down there when it goes into self test mode and if you get voltage, your speaker is bad. Otherwise you have either a wire issue or a head unit issue. But if you have a good ground and you aren't getting power/current, then you should trace the power wire to the head unit (if you can). Hope this helps someone out.

The only thing I ask from you is that you try on your Explorer and then post back on here your year, model, and possibly radio choice (premium or not). Thanks

-Drew
Hey...thanks for the info...it's cool.
I tried it on a 98 Explorer Mach CD/radio/cassette and a 98 Explorer Premium
CD/Radio/cassette...worked on both.

There's a sticker on the bottom side of the radio that identifies the type of radio....Mach, Premium, or standard.


Thanks.
 




Bakari

Member
Joined
June 11, 2006
Messages
28
Reaction score
0
City, State
AL
Year, Model & Trim Level
'95 Eddie Baurer
Pretty cool! it worked on my 95 Eddie Bauer..cassette with the built in amp...I will have to try this again when the 1999 factory CD with built in amp unit gets installed :)
 




VDub2625

Active Member
Joined
May 28, 2006
Messages
75
Reaction score
0
City, State
Fall River, MA
Year, Model & Trim Level
'97 Explorer Sport
FYI... just tried this on my '97 Sport (I think it's the premium? It has a Casette, rear controls, but no changer), it works. Does it also test the changer, becuase it told me that no DJ was attatched.

Also, I tried every other combo I could think of, and 3 and 5 was the only other one that did something: it disabled the rear controls :D I'm sure you people knew that, but it was exciting for me :p
 




JusExplorin

Member
Joined
April 7, 2007
Messages
10
Reaction score
0
City, State
Jacksonville, FL
Year, Model & Trim Level
2001 XSport
2001 Xsport with Pioneer 6CD HU worked
 




VDub2625

Active Member
Joined
May 28, 2006
Messages
75
Reaction score
0
City, State
Fall River, MA
Year, Model & Trim Level
'97 Explorer Sport
Hmm, it didn't work on my new radio ('98 single CD w/selective lighting). I can't turn off the rear controls either.

EDIT: on the original 97 HU, it only takes a quick push of the buttons. On this one, you have to hold them for a few seconds :D
 




IAmTodd

4x Explorer Veteran
Joined
April 8, 2002
Messages
8,887
Reaction score
7
City, State
Johnstown, PA
Year, Model & Trim Level
2015 Jeep
Works with my Ranger unit. Had a couple DTCs, but I couldn't track down what they were related to.
 




E.B. Cornburner

Explorer Addict
Joined
April 20, 2007
Messages
1,137
Reaction score
5
City, State
Oshkosh, WI
Year, Model & Trim Level
2004 Eddie Bauer
That's pretty slick! It even tests the subwoofer.
 






Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




IAmTodd

4x Explorer Veteran
Joined
April 8, 2002
Messages
8,887
Reaction score
7
City, State
Johnstown, PA
Year, Model & Trim Level
2015 Jeep
For the radio.
 




Top