Fast Ticking during acceleration. | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Fast Ticking during acceleration.

Mjaga251

Member
Joined
February 10, 2007
Messages
42
Reaction score
0
City, State
St. Charles, Illinois
Year, Model & Trim Level
1999 XLT
When Im accelerating there is a fast ticking coming from the front passenger side. The faster the acceleration, faster the ticking. It sounds like it would be a rock in the tire, but its not! Anyone have any ideas on what could it be?
Thanks in advance.

-Mike
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




<



Mjaga251

Member
Joined
February 10, 2007
Messages
42
Reaction score
0
City, State
St. Charles, Illinois
Year, Model & Trim Level
1999 XLT
Nope, I've got the 4.0 SOHC.
 
<



budwich

Explorer Addict
Joined
May 4, 2005
Messages
3,245
Reaction score
4
City, State
Ottawa, Ont
Year, Model & Trim Level
96 XL
My guess would be your timing chain / guides especially on an sohc.
 
<



Mjaga251

Member
Joined
February 10, 2007
Messages
42
Reaction score
0
City, State
St. Charles, Illinois
Year, Model & Trim Level
1999 XLT
Hmmm...any guess on how much it'd cost to get fixed at a dealer?
 
<



budwich

Explorer Addict
Joined
May 4, 2005
Messages
3,245
Reaction score
4
City, State
Ottawa, Ont
Year, Model & Trim Level
96 XL
its not pretty from the posts here.... but wouldn't there that fast... that's was just my "first guess". I would go check your tire again for things like a screw / nail where the head has been worn off... those can cause that sound. You indicate that its only on acceleration, if you stay at a constant speed, then there is no ticking, right? what about in neutral and revving... any noise. Is it possible that you are hearing "pinging" instead of "ticking".... which is related to pre-ignition or too lean a mixture? As it go thru gears (depending on what you means by "hard acceleration"), does the noise still continue with each change? Also check on your wires for cracks where perhaps arcing is occuring. Hopefully some other ideas will come forth. You probably need to isolate things a bit more. What about running is 4wd (high or auto)... does it change under these conditions (ruling out some form of transfer case issue). What about moving you steering during the acceleration... any impact?
 
<



Top