Finally finished my system (pics inside) | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!
    If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Finally finished my system (pics inside)

Holty

Well-Known Member
Joined
April 15, 2002
Messages
372
Reaction score
0
City, State
Pittsburgh, PA
Year, Model & Trim Level
'99 Explorer XLT AWD V8
I have been sub-less for over a year now since i started putting my system in. I started out with the intentions of installing a system without a sub because at that time i could not afford EVERYTHING right away so i decided to do the mids and highs right the first time and then when i had the money add the sub later on. Well, i finally got around to finishing the system with a sub and everything sounds AWESOME! I can't believe i've gone this long without bass. I listen to everything from rap to country (except punk, i hate punk) and the addition of the sub makes everything sound so much better. I'm very proud of this setup even though there are alot bigger and better systems out there, this one is perfect for ME. :D

here is a list of the components installed:

Alpine CDA-7894 MP3 Headunit
JL Audio XR650 components in the front with adjustable xovers
Infinity Reference 5752cf's in the rear
Kicker ZX460 4-channel amp running the mids & highs
JL Audio 12W3v2 dual voice coil sub
JL Audio 300/2 amp bridged mono
 

Attachments

  • 640x480head unit pic1.jpg
    640x480head unit pic1.jpg
    83.8 KB · Views: 303



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.























Holty

Well-Known Member
Joined
April 15, 2002
Messages
372
Reaction score
0
City, State
Pittsburgh, PA
Year, Model & Trim Level
'99 Explorer XLT AWD V8
here is a pick of how i had it wired up before adding the sub.

lesson #1: if you leave your wiring looking like this your asking for trouble. I had alternator whine something terrible until i fixed up the wiring.
 

Attachments

  • 640x480old wiring1.jpg
    640x480old wiring1.jpg
    77.3 KB · Views: 287






Holty

Well-Known Member
Joined
April 15, 2002
Messages
372
Reaction score
0
City, State
Pittsburgh, PA
Year, Model & Trim Level
'99 Explorer XLT AWD V8
Here is the wiring now after taking time and doing it right!

:rolleyes:
 

Attachments

  • 640x480new wiring.jpg
    640x480new wiring.jpg
    88.4 KB · Views: 285






Fish Man

Explorer Addict
Joined
April 13, 2002
Messages
1,803
Reaction score
0
City, State
Chattanooga TN
Year, Model & Trim Level
1995 Explorer XLT
looks nice...that wiring is much better now ;)
 






Alec

Elite Moderator
Moderator Emeritus
Joined
April 25, 2000
Messages
15,979
Reaction score
1
City, State
Houston, Texas
Year, Model & Trim Level
2008 JK
Nice work on those floor flaps.
 






UtahX

Explorer Addict
Joined
September 30, 2003
Messages
1,107
Reaction score
41
City, State
Grand Junction, Colorado
Year, Model & Trim Level
2000 Explorer XLT
Holty,

I put my amps in the same place as yours, but ran the wires throught the crack on the right side. We thought about slicing the carpet, but decided the other way was better. Is that a 12"? Which model? What else did you get? Looks like a Alpine deck, which one?
 






davesexplorer

Explorer Addict
Joined
March 13, 2001
Messages
2,736
Reaction score
1
City, State
Central PA
Year, Model & Trim Level
2001 F350 7.3
looks like a real nice setup, how does it sound...? great I'd guess....
my g/f has the same HU, I love playing with it when Im riding in the car..
 






Top