Front End Noise | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!
    If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Front End Noise

BadAzzexplr

Member
Joined
March 29, 2002
Messages
31
Reaction score
0
City, State
Boston, MA
Year, Model & Trim Level
97 XLT 5.0 AWD
I have 1997 Ford Explorer V8 AWD. I recently am running to a problem where I have a clunkying noise when i go over bumps. I checked my sway bar ends and the bushings were worn, so I replaced them. Within in two weeks they worn again. I have put new shocks on the front end, upper control arm left and right, upper ball joint, lower ball joints and sway bar bushings. I am completly lost because I just put in Moog Poly bushing sway bar ends and I thought I solved the problem and after a week they are worn and loose and the noise has returned.

Anyone have any ideas, I don;t do any off roading. I mostly do highway driving.


any help would be great
 






Jason_25

Elite Explorer<br>ECX Member
Joined
November 26, 2000
Messages
5,339
Reaction score
6
City, State
New Bern, NC
Year, Model & Trim Level
'95 Explorer "Expedition"
Can you take a picture of where they are worn? That does not sound normal at all. Makes me think the end links may not be put together right.
 






BadAzzexplr

Member
Joined
March 29, 2002
Messages
31
Reaction score
0
City, State
Boston, MA
Year, Model & Trim Level
97 XLT 5.0 AWD
I will try to take a picture. How do you upload them? Also I forgot to add its always the right side sway bar end that becomes loose. I am able to turn the post in a matter of 5 days. Another thing is my right tire is wearing on the inside and I had the alignment checked and it was in spec.
 






BadAzzexplr

Member
Joined
March 29, 2002
Messages
31
Reaction score
0
City, State
Boston, MA
Year, Model & Trim Level
97 XLT 5.0 AWD
I have pin pointed the problem I think, the outer tie rod end has alot of play on right side. When I bounce the truck sometimes I get a vibration and squeak. This joint I belive is sealed, so the soloution is to replace it? The part that is squeaking is the one closest to the wheel, it makes a similar noise to when your control arm is going.
 






Top