front speakers | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

front speakers

Jkuehlman

New Member
Joined
July 4, 2021
Messages
5
Reaction score
0
City, State
ISSAQUAH
Year, Model & Trim Level
2014 police utility, ford
My front speakers do not work at all. anyone have any idea on which fuse is for these ones? Also If anyone has any AC issues and fixed it could you shed some light? I recharged it but still only hot air.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





I don't think I've heard of speakers having fuses. It could be an issue with the ACM (Audio Control Module).

Peter
 












If there are other speakers, are they working? There are no fuses shown in your Manual for the speakers. Some amps may have inline fuses but I don't know if that applies to the PIU.
 






I know on mine, when it was taken out of service many wires were left disconnected, including the front speakers. A pain to trace the wires, but maybe you will see them unplugged from back of head unit.
 






My front speakers do not work at all. anyone have any idea on which fuse is for these ones? Also If anyone has any AC issues and fixed it could you shed some light? I recharged it but still only hot air.
If your speakers haven't worked since you got the vehicle then perhaps what Eric mentioned is the reason why. I thought that they had simply quit working.

Peter
 






Back
Top