Fuel delivery issue, possibly electrical? | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Fuel delivery issue, possibly electrical?

JG88

New Member
Joined
September 19, 2011
Messages
9
Reaction score
0
City, State
Philadelphia, PA/Long Island, NY
Year, Model & Trim Level
97 Explorer Sport 2DR 4WD
Hey everyone,

This is my first post here, but I've been utilizing the site for about five years now, and the information provided on these forums has been invaluable. Thanks to everyone for unknowingly helping me these past few years!

Currently, I am having an issue with fuel getting to my engine, and I can't seem to find the source of the problem (possibly because I don't want to admit the fuel pump may need to be replaced because it's a PITA). I have a 97 explorer sport 2-door 4wd.
Backstory:
For about a year now my ex has had an intermittent problem where it wouldn't start after being driven for a while. This usually only happened when I took a 120-mile trip from Long Island to Philadelphia and pulled over in a rest stop. After turning the car off, it would rough idle and then stall when I tried to start it back up, and I would have to wait a half-hour for it to cool down before it would run fine. After it started, it would run like a champ the rest of the way home.
This summer I put a fair amount of unrelated work into the vehicle that it had needed for some time (new radiator, heater control valve, serpentine belt, ECT sensor, plugs/wires, fluids flush/change, air filter, and an audio system). After finally getting all that done the no-start happened more frequently, and within two weeks started happening every time I would drive it for more than 10 minutes. Sometimes spraying the throttle body with ether would get it to start; other times I wasn't as lucky.
About two weeks ago I made the 120-mile trip to NY and the truck ran perfect. After getting here, I let the truck sit for a couple days. When I tried to start it, it took a couple seconds of it turning over but eventually it caught. The next day when I tried to start it, I got nothing, and that's where I've been for the past week.

I've been attempting to diagnose every part of the fuel system to make sure everything works. I'm positive it's not spark or position sensors because I've sprayed 1/3 can of either into the throttle body (horrible idea, I know) and it ran for a good 20 seconds before it fell on its face. I've checked/swapped relays and fuses. I've checked the voltage across the fuel pump relay...12V across both the constant side and the switched side. Inertia switch is functional.

Here's where it gets strange: I figure the only thing left standing between me and a rage-filled day of changing a fuel pump is the chance of a corroded connection somewhere. I decided to grab a wiring diagram and test the wiring at the inertia switch. According to the diagram, the Dark Green/Yellow wire is supposed to run directly from the fuel pump relay (which tested 12V) to the inertia switch. Key off: 0v. KOEO: 6v. Well...that's wrong. I keep the meter on it for a while and realized the circuit wasn't switching - I had a constant 6V. That's even more wrong. I retested the relay and there's still 12V there. I start to guess part of the problem is that I have a bad wire bundle somewhere.

The wiring diagram says that the only power source should be the Green wire. If the switch is working correctly, it routes the power to the Pink/Black wire which runs directly to the fuel pump. If the switch opens, it routes power to a Gray/Orange wire that runs to the instrument panel. For some reason, I decide to test the Gray/Orange wire. With one meter lead on the wire, and the other ground to the chassis, I get a 12V-swiched reading. Whaaaat!? Maybe I've failed at reading the wiring diagram, but I'm pretty sure that's not supposed to be a current supply wire.

Sidebar: If I take a reading on that wire with a meter, the Fuel Reset light does not illuminate. However, if I take a bare piece of wire and connect the Gray wire to the Pink wire, the reset light will illuminate. Anyone care to explain how this circuit functions?

As far as I can tell, the fuel pump requires 12V, but is only getting 6V from the junction at the inertia switch. So to try to get the fuel pump to prime, I ran a wire straight from the positive lead of the battery to the pink/black wire. With that hooked up, I turn the key to On and test the schrader valve on the fuel rail with a flathead....nothing.

Keeping the same setup, I begin a rampage with a hammer. I bang every exposed part the fuel tank trying to actuate the pump, and I even gave the fuel filter a few taps in case there was a blockage in there (there shouldn't be, it's only 2 years old). I repeat this multiple times and keep returning to the schrader valve to check the pressure. Sometimes I get a little squirt of gas, sometimes a dribble, sometimes nothing.

Continuing with my tirade of proving to myself it's not the fuel pump, I test the connection I've made to the Pink/Black wire. Originally I was getting 12V from the battery to this wire. Now when I put the meter on it, I get a reading of 3 volts that decreases down to 0 volts within five seconds. If I wait a few seconds and test again, I get the same thing. Could there be a loose connection on the fuel pump that I've knocked loose by hammering the tank?

I've tried tracing the wire to the pump, but I can't find it. I've found one wire bundle coming through a boot next to the fuel tank, but I cant find a Pink/Black wire in that. Does anybody know where exactly this wire runs? Also, are there any known wire/bundle problems or fuseable links to the pump? Any other ideas what it could be? I'm a pretty broke college kid, hence why I'm trying to find a reason why the fuel pump isn't the problem. If I have to replace the pump, does anybody have a pic of cutting an access panel to it in a 97 2-Door? I've seen a few threads on it, but the best I found was on a 97 4-door.

Thanks, everyone!
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





"smells" like a bad pump to me... but it could be your testing... :-)

IF you can't get your vehicle to run/start by running a wire directly to the "direct connection" of the pump, then it is LIKELY a pump problem.

A "course in electronics" should now be high on your college studies... it could be useful in your future... :-) That "course" is beyond the scope of this thread.... and I probably have to kill you AND me... :-)

Anyways, we'll start slow.... throwing a wire from the GY/O to the PK/BK just provides a circuit path for the light ... exactly what the inertia switch does... NO it doesn't switch the incoming power lead (DG/Y) to the GY/O.

Next when you were measuring voltage on the DG/Y and getting ~6v... this is the voltage within the PCM circuitry that you are "seeing"... because there was no 12v coming thru the relay contacts on the fuel relay for whatever reason (most likely not operated).

Lastly, the motor is suspect when you ran a direct wire to the motor and got ???? voltage.... BUT it could also be that you have a poor connection at the other end of the wire OR a poor ground where you are metering from (which is were???? ie. where is your meter black wire hooked to when you are making each of your measurements???

Lastly, measure the resistance of your motor and see what you get... that will give you a hint about its condition ... maybe...... IF you are doing it correctly AND the ground(s) and connections are good (could be the problem also... which you will have to get close to the pump to see/test properly.

Good luck, overall good work but keep going... :-)
 






Thanks for the quick reply, budwich.

I guess I should add a link to the diagram I'm referencing:
http://www.justanswer.com/uploads/AutoTechInSTL/2007-11-27_234834_ja1.gif

I swear it looks like DG/Y gets switched to GY/O, but I guess I'm just bad at reading diagrams. I've always been interested in electronics since I was a kid, but I've always found myself in way over my head (why you need two resistors with the same rating on each end of circuit to split the current in the middle by that factor instead of just one resistor at the beginning will remain a mystery to me no matter how many times somebody tries to explain it to me).

To get the readings from each pin and from the wire running from the battery, I found a clean ground on a bolt mounted under the dash. Putting the red lead on the wire from the battery and the black lead on the bolt I get a constant ~12v reading. Same idea with the readings from the rest of the pins. Then to get the reading going to the pump, I put the meter inline: wire from battery -> red lead -> black lead -> PK/BK. This is where I originally got the 12V reading going to the pump, and now its somewhere between 0-3V.

Can I measure resistance between the PK/BK and a chassis ground, or do I need to be right on the pins on the pump? Also, do you have any idea what the resistance should be?

I guess I'm going to try to trace the PK/BK wire to the pump. If it looks fine, I guess I gotta change it.

Thanks for your help!
 






well that explains the ???? reading going to the motor. Not sure where you learned about meters but reading voltages of a circuit is NOT DONE by connecting the meter "IN LINE" but in the same manner as you did with all your other measurements. By connecting your meter in-line, you basically "asked it" to become "part of the circuit" and that not going to do you anything (of course, measuring for current is a different kettle of fish... we won't go there).

In terms of testing with your jumper wire from the battery "direct" to the pump... connected up, try and start the engine... the pump will run all the time if it is functioning. Measuring the voltage at the junction of the jumper and the PK/BK lead with your meter black lead on the bolt that you have always used.... it should / better read 12v continuous otherwise your jumper wire is bad or the connection at the battery is no good.

PS. schematics (unofficial and even official) can be "misleading"..... anyways, I stick to my "story" about the cluster indicator as "my schematic" (96) shows the switch a bit different with the arrow pointing from the PK/BK lead. You can test it easily by activating the switch and then measuring which contacts are connected. No problem though as you were asking why your test "worked" in a given fashion.
 






J88: You are making this much too complicated; plus as budwich points out your testing technique is faulty. This is a classic fuel pump failure story - starts out intermittant and gets slowly worse. Operationally, here is what happens: When the key is turned on, the fuel pump relay operates and puts 12V at the PCM fuel pump monitoring pin and the input side of the inertia switch (your DG/Y wire). If the inertia switch is in the "normal" position, it in turn puts 12V on the wire to the fuel pump (your Pk/BK wire). If the inertia switch is in the "tripped" position, it instead puts the 12V to the indicator light (your Gy/Or wire) and your indicator light goes on. If you really want to confirm that your pump is bad, you need to crawl underneath, reach up to the top of the tank, unplug the connector to the fuel pump; and measure the voltage between the PK/Bk and ground. If it's 12V, you have the correct power to the pump and the pump is almost definitely bad. To clear the last possible alternative problem, measure continuity between the chassie and the ground pin on the connector to insure that there is not an open circuit there.

Sorry, but I have no idea where to put the fuel pump access hole for a Sport. Good luck
 






Thanks for the replies fellas.

I finally folded and went out and bought a new fuel pump. I chiseled a hole through the floor this morning, and I'll be putting the pump in later today. At least now I can give a little back to the forum :) I'll have pics a little later today when I find my camera.
 






Thanks for the replies fellas.

I finally folded and went out and bought a new fuel pump. I chiseled a hole through the floor this morning, and I'll be putting the pump in later today. At least now I can give a little back to the forum :) I'll have pics a little later today when I find my camera.

definitely interested in seeing where you put the hole as hopefully its the same spot on my 98 sport.
 












Back
Top