• Register Today It's free! This box and some ads will disappear once registered!

fuel pressure


1loudsuv

New Member
Joined
December 20, 2005
Messages
16
Reaction score
0
City, State
long beach,ca
Year, Model & Trim Level
98 explorer xlt
ok my truck has always took a long time to crank sometimes up to 5 seconds and sometimes it starts right away.

for about 2 years its been doing that dindt really pay to much attention to it. the fuel presure is in the high 40 range when its running (adjustable regulator it can go up or down) but when i turn the ignition on wihtout cranking hte pressure stays at zero im not sure if it jumps up and jumps back down but by the time im up to the front its at zero

same thing when i turn it off


well yesterday it started like misfiring hesitating. im gonna change the plugs cause its been a while ive done that

but i dunno im leaning towards a leaking injector how would i go about checking if its an injector leaking or of the valve in the fuel pump is bad? i really dont want to buy 8 injectors and then find out its just the fuel pump and vice versa
 




1loudsuv

New Member
Joined
December 20, 2005
Messages
16
Reaction score
0
City, State
long beach,ca
Year, Model & Trim Level
98 explorer xlt
let me add that the iac the tps the mass air flow is all about a year old.

so i doubt its any of that.

im putting it down to this

the wires or plugs
or leaking fuel injector/s or fuel pump check valve

im hoping its just the plugs. cause car problems suck im just waiting on my freind to call so we can check them and change them
 




1loudsuv

New Member
Joined
December 20, 2005
Messages
16
Reaction score
0
City, State
long beach,ca
Year, Model & Trim Level
98 explorer xlt
3 plugs had the electrodes burnt up guess thats what 180 shot of nos does. problem fixed as af now lol
 




Top