Fuel pump blues. | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Fuel pump blues.

kpkrull

New Member
Joined
October 28, 2009
Messages
1
Reaction score
0
City, State
deatsville alabama
Year, Model & Trim Level
1993 eddie bauer
hey now everybody ! i got a problem maybe someone can give me an answer. i have a 1993 explorer eddie bauer. the truck stopped running like it ran out of gas. did all the diagnostics, fuel pump relay, inertia switch, fuel pump fuse, ect ect, and everything points to a bad fuel pump. well i have replaced the fuel pump, and still no fuel...... checked relay, fuses, and inertia switch again, still nothing. any ideas? could my new fuel pump possobly be bad?
 




BobWiersema

Explorer Addict
Joined
November 5, 2008
Messages
1,292
Reaction score
5
City, State
Chicago Burbs, Illinois
Year, Model & Trim Level
98 xlt 4.0L SOHC 4x4
Can you here the pump run for a second or two when you turn the ignition on?
 




BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,121
Reaction score
690
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars




MrShorty

Explorer Addict
Joined
December 27, 2001
Messages
5,078
Reaction score
16
City, State
Spanish Fork, UT
Year, Model & Trim Level
92 XLT and '87 Bronco II
In addition to BrooklyBay's suggestions to check for power to the PCM:
did all the diagnostics, fuel pump relay, inertia switch, fuel pump fuse, ect ect, and everything points to a bad fuel pump.
May I ask how you tested these? Does the fuel pump relay close when you ground the test connector (short end of the trapezoid in the self-test connector)? Do you have +12 V at the fuse? When the relay is closed, do you have 12 V at the inertia switch? at the fuel pump connector? did you check the fuel pump's ground?
 




Top