Gremlins in Speedometer/Odometer | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Gremlins in Speedometer/Odometer

Georgia_Birdman

Active Member
Joined
April 29, 2017
Messages
61
Reaction score
7
City, State
Marietta, GA
Year, Model & Trim Level
1998 Explorer Eddie Bauer
My speedometer/odometer is having an intermittent problem. Most of the time they work OK, but every so often, they just stop. I notice that the speedometer needle goes all the way to zero and the odometer stops turning over. Sometimes it will stop and start repeatedly then just quit. When I drive the vehicle after a while of being parked, it will work again. Sometimes, I can knock on the instrument panel and it will start working again. Knocking isn't working anymore now. I ruled out the speed sensor in the rear end by verifying the operation of cruise control. I feel that the trouble is in the cluster itself.

Does anyone have any ideas?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.











the connection to the dash panel is a push in and clip ribbon style,, they can get loose,, take it out , make sure it clips back in properly,, put the dash back together,
 






95-97 trucks have issues with the small black gear breaking inside. 98+ guts can be swapped in and are upgraded.
 






95-97 trucks have issues with the small black gear breaking inside. 98+ guts can be swapped in and are upgraded.

Where is the black gear ?

Where is the guts ?

ThanX
 






It's on the speedo motor above the odometer. Pull the cluster. Take the glass off, pop outer gauges out then you can pull the center speedo/tach out. It's on the back side of there.
 






I jiggled all my fuses and the speedometer and odometer both started working again. I don't know what fuse was loose. Which fuse protects the speedo/odo circuit?
 






Back
Top