ground help | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

ground help

brian_dupuis

New Member
Joined
January 13, 2010
Messages
4
Reaction score
0
City, State
Fairborn, ohio
Year, Model & Trim Level
1998 Explorer xlt
My explorer broke down one day, and i had it towed to the tow yard and had them look at it. (im not the smartest with engines). They said I needed a new motor. But they only had it for about 45mins before they called me. Well when i got it home, I checked the oil and it was all crusty (i know not good, but my brother had it for 6 months before i got it back when i got home from basic). But as I noticed i had this gray strap (hanging) not hooked anything. I wanna say its a ground.

The reason I say ground is because when i put the key in to start it, i go to turn it over and everything shuts off, then i dont have my radio stations or anything programed. When it does that i cant turn it over or anything.

In the picture its the strap hanging. Its hooked on the top left side, but i need to figure out where the bottom part hooks up. All your help is appreciated.

th_0312001726.jpg
 
<



rednecksoldier

Active Member
Joined
November 11, 2008
Messages
88
Reaction score
0
City, State
Loganville, Georgia
Year, Model & Trim Level
91 xlt
that usually hooks to the hood i think but im sorry to say that aint your problem! i took that strap off all together on mine and it still runs perfect. check the ground on the battery and where it hooks on the block or frame make sure its clean and tight and then check your battery terminals they might be worn down too much! sounds like an electrical problem to me :)
 
<



Top