HELP 89 Bronco II No Spark | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

HELP 89 Bronco II No Spark

MLB

New Member
Joined
June 6, 2010
Messages
3
Reaction score
0
City, State
Oklahoma
Year, Model & Trim Level
88 Bronco II
I've got an 89 Bronco II with the 2.9 with no SPARK, I have installed a new TFI, plugs, wire, dist. cap, rotor button with still no luck. I also have an 88' I swapped the known good coil and computer and still no spark. I bought this truck from a friend, while replacing the coil he crossed the positive and negative terminals on the coil after that is when it lost the spark. your help and ideas would be greatly appreciated. This is a nice truck, I would really like to get it back on the road. Thanks.
 
<



B2-Bomber

Member
Joined
May 15, 2013
Messages
28
Reaction score
0
City, State
SL,UT
Year, Model & Trim Level
1988 V8 EXPLONCO FW SAS
are you getting switched + to the red wire with green stripe at the coil? checked fuses? there is also a fusible link built into the main feed wire (black with orange stripe) but if that one had popped you would have lost power to many other things too.
 
<



MLB

New Member
Joined
June 6, 2010
Messages
3
Reaction score
0
City, State
Oklahoma
Year, Model & Trim Level
88 Bronco II
I've got 12 steady volts at the coil terminals. Maybe the pick up coil ???
 
<



B2-Bomber

Member
Joined
May 15, 2013
Messages
28
Reaction score
0
City, State
SL,UT
Year, Model & Trim Level
1988 V8 EXPLONCO FW SAS
IIRC, the pick up coil in a TFI distributor creates an AC current "Hall-effect" signal that the TFI module (bolted to the distributor) converts into a square wave pulsing signal to be used for sparking/injector signal reference.

this style is difficult to bench test. You are certain that the tfi module is good?
 
<



Top