Help! '96 gran marquis, dead. no power to the EEC | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Help! '96 gran marquis, dead. no power to the EEC

Doubt Incarnate

Well-Known Member
May 9, 2005
Reaction score
City, State
"Franktucky", Ohio
Year, Model & Trim Level
'99 Eddie Bauer
My brothers car: 1996 mercury gran marquis, it snapped a balljoint, still ran. came home on a flat bed, we did the balljoints... now it no starty. What can keep the EEC from getting power? we swapped fuses, relays, cleaned connections, even pulled a couple EECs this morning and tried those, nothing. engine cranks, no fuel, no spark, no nothing. i just took the ignition switch apart and cleaned it up, no-go. i bypassed the fuel pump relay to see if the pump was bad first, it primed the rails, and still no starting. the inertia switch never tripped, so i thumped it and reset it, nothing. i hate this car.

is there a fusible link? do they still put those in cars after 96? brother says he checked the ground connection, i didnt, thats the only other thing i can think of if there isnt a fuseable link somewhere.

Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!

i't looks like everything is normal when you first turn the key, but i'll double check that. i know the code reader comes up with "error", which makes me think the eec isnt powering up to show a code.

no check engine light when you turn the key to on. we just checked things with a voltmeter, there is 12v at the fuse on one side of the car, but the relay and diode on the other side arent getting anything, and the pins at the eec connector show a whopping .25v. all the grounds check out good for continuity.

actually the relay sockey for power was 12 i think, but the command to activate the relay was 0. the 2 "hot in run or start" pins on the eec connector reaad .25v probly just finger volts tho

there is 12v at the fuse, fuse is good. i'm going to run a wire from a 12v source to trip the relay and see if the eec will start the car. if so then something isnt telling the relay to trip, probably a wire since we replaced the ignition switch yesterday. we've swapped a few relays through so i'm sure its not the relay

what i was going to do is feed 12v to the signal side of the relay to trip it, that way the relay, fuse, and diode still do their thing. i'll go jumper the power lines in the relay socket and listen for the eec to prime the pump

the eec fires up and runs the fuel pump. truned the key and it still didnt fire. when my brother and i are home tonite weel check for spark when its darker. the check engine light came on in the run position this time, so that looks hopefull

maybe, its a 96 and there is no chip in the key. maybe something to do with the radio? its had an aftermarket unit for like 5 years so that doesnt make sense. i've got to keep up with my explorer so i'm turning this one over to dad tomorrow. at least you can smell gas when its cranking now, if its not sparking would that have anything to do with the eec not getting power? it wouldnt make sense to me that if a module went bad then everything woulld be cut out, you'd think they leave the eec alive to throw a code.

no alarm, we've had this sucker for 7 years and its was all stock.

solved! we isolated this down to the signal wire for the EEC relay. turns out that thing also feeds power to the 2 coil packs. As it were, when the ball joint snapped off, the car dropped, and the drivers wheel came up farther than normal into the fender well. i suspect it came up and the rubber pinched the wire harness running through the fender and severed a couple wires. they spliced them up and it took off as normal. thank god, i would hate to call a wrecker to tow that crap from my driveway under my brother

its between the interior fuse block and the relay. the wire that energizes it to put power through