help with a coil creak please | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

help with a coil creak please

live2_4x4

Well-Known Member
Joined
December 11, 2004
Messages
118
Reaction score
0
City, State
Kamloops British Columbia
Year, Model & Trim Level
1994 XLT
I recently replaced the radius arm bushings on my 94 ex. and after reassembly I have a creak that appears to be coming from the coils spring on both sides. I have disconnected the swaybar and shock and used a jack to cycle the suspension and the noise persists. However if I pull the coil and cycle the suspension it is silent. The noise was not present prior to the radius arm bushing replacement. When I replaced them I used the method that did not involve grinding rivets out, and cleaned all parts prior to replacing them. Is this noise a settling in noise or did I do something wrong? Any idea where to start looking?
Thanks

Glen
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





1st. did you remove and/or forget to reinstall the nylon/plastic spring isolater on the lower coil mount? 2nd. make sure the spring is fully seated and the coil is alinged in the pocket properly. If it is there will typically be some poping/creaking for the first couple of miles, but if it continues there is something not letting the spring seat properly.
 






I did remove the isolator but I also did replace it. It does appear to be in poor shape but did not make noise before removal and cleaning. As far as properly seated it appears to be in the correct location as near as I can tell. I drove the ex. about 40 to 50 km after the radius arm job, but the noise did not go away. Any more ideas?

Glen
 






poly bushings tend to squeak; rubber not so much

Poly bushings tend to squeak and rubber ones tend not to. Did you install poly bushings (e.g., Energy Suspension) or some sort of rubber ones? The Poly ones might even squeak if you apply the special poly bushing grease but that would help.

I'm grinding out my rivets and installing Energy Suspension bushings in the next week or so. I also bought a container of the E.S. special grease and plan to use ALL of it (my BMW sway bar bushings squeak like crazy; I didn't use enough grease). :(
 






How do you know when coil springs are bad

How do you know when to replace coil springs. I was driving across a bridge recently and my explorer was bouncing up and down like crazy. I replaced the shocks about a year ago. Does this mean the coils might need replacing?
 






Holy hijack...

To pinpint the creak, jack it back up as before, and cycle the suspension to make it creak. Take some WD-40 and spray suspect areas (do small areas, one at a time) until the noise goes away. When the noise stops, you've identified the culprit. Anything else is guesswork.

As for the coil/bouncing issue, I'm not a suspension expert, but I've been taught that bouncing is bad shocks. If springs go bad, the vehicle will sag. Mainly, springs don't go bad in the sense that they get weak and bounce, they just break and don't hold the body at the proper height.

Hope this helps.

Mike
 






Thanks Mikeinri...

Yeah, that info does help. Thanks for the fast response.
 






I also have a new sound, groan sound from spring on front passenger side of a 92 2wd xlt. Started after I replaced the RA bushing using the non rivet removal approach (disconnected the sway bar and shock, pulled the I beam forward) when I got it all back together I got one loud pop noise, like the spring reseated, no other pop noise except the one. now when I boune the front end I get the grown sound. I noticed the spring seem to be turned some when compared the the quiet driver side. I can see the end of the spring point out the side, whereas on the driver side I can't see the end. Sort of like the spring turned 45 degrees. Does the spring have to be in a particular orinatation the to seat? I did not remove the nut which retains the spring on the bottom but I guess I could have spun it some while putting back together.
 






ok found a pic in the manual that shows the correct orintation of the spring, I am 90 degrees out, so will try that first to see if I can get rid of the noise I get when bouncing the front end.
 






ok so I was not 90 degree out, when I got the wheel off and took another look at it I realized the top of the spring kinda has a correct "fit" into a pocket. when I was looking at the hayes manual it was not that clear (hence I thought I was way out). Anyway I compressed the spring, lowered the spindle, turned the spring maybe 5 degrees so it would fit in the pocket with the end of the sping seeming to be where it would belong, and tried again. Maybe premature, but I think I got it now, I bounced the front a few times and no groan or creak. Will see next time I take it out on the road. My guess is if the spring is not positioned so the end of the spring is captured, then when compressed it can rotate ever so slightly, enough to make the sound. The saga continues. I got this car new back in 92, never did much wrenching on it, just 3k oil changes, and now 15 yrs later I have renewed my interest in trying to do automotive work to keep it going. So far it seems pretty easy to work on.
 






Back
Top