Help | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

cammingle

New Member
Joined
December 11, 2008
Messages
2
Reaction score
0
City, State
buffalo new york
Year, Model & Trim Level
91 explorer
I have a 94 ford explorer and it has had many problems but its become my project and I refuse to give up on it so..
I bought it and it would only start on the thrid try. It ran very sluggish when you would take off it would almost stall eh it really didnt stall but it would seem that the engine would cut off let off the gas and it would pick back up cant go over 50 on a good day and it seems the less gas it had in it the better I dont know why So I Started work
I replaced plugs and wires. I replace the fuel filter and a exhuast line that had rusted right through. I have filled the tank and used injector cleaner and nothing its only gotten worse now that the cold weather is here it dont want to run at all it will start after some trys and then stall hit the gas and it stalls right away any ideas I'm lost someone said coil pack but I'd like to know what everyone thinks PLEASE!!!:confused:
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




Dopler174

Official Welcome Committe
Moderator Emeritus
Joined
February 21, 2005
Messages
4,998
Reaction score
2
City, State
Greensboro, NC
Year, Model & Trim Level
1993 XLT 4X4
I was thinking coil pack...
 
<



BrooklynBay

Moderator & long time member.
Staff member
Moderator
Elite Explorer
Joined
November 11, 2005
Messages
55,229
Reaction score
714
City, State
Brooklyn, NY
Year, Model & Trim Level
88 89 93 95 96 Aerostars
<



cammingle

New Member
Joined
December 11, 2008
Messages
2
Reaction score
0
City, State
buffalo new york
Year, Model & Trim Level
91 explorer
Yes I did replace the fuel filter and a erg or egr valve sorry new to this whole thing
 
<



marragtop

Explorer Addict
Joined
April 14, 2001
Messages
2,075
Reaction score
0
City, State
balt, md
Year, Model & Trim Level
91, 92, 95, and 2000 xlts
Check the vacuum lines on the vacuum tree located on the drivers side near the firewall. A disconnected line could give you the symptons that you have.
 
<



Top