Here is a video of my A/C Compressor - is something not right? | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Here is a video of my A/C Compressor - is something not right?

King$nake

Well-Known Member
Joined
May 19, 2006
Messages
505
Reaction score
0
City, State
Oceanside, CA
Year, Model & Trim Level
1998 Eddie Bauer 5.0
Hello,

I just installed my new compressor after flushing the entire A/C system, replacing the condenser, accumulator and orifice tube. Had the system evac'd and charged.

I notice immediately that the new A/C compressor is very noisy, and you can hear it over the 5.0 exhaust when the clutch on it starts/stops. I've uploaded a video, is there something not right here?

It seems to be blowing pretty cold air so far though, and the accumulator is dripping with condensation and is cold, so the freon seems to be circulating, atleast for now.

Here is the video, let me know (also notice the low pressure side gauge):

 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.








King$nake

Well-Known Member
Joined
May 19, 2006
Messages
505
Reaction score
0
City, State
Oceanside, CA
Year, Model & Trim Level
1998 Eddie Bauer 5.0
Cool man, Im probably just paranoid. I've been through the ringer with this A/C system in the last few weeks, I wish I wasn't so stubborn or I would have just left it alone and gone without A/C altogether, but I had to fix it lol
 




4rd Xplora

Elite Explorer
Joined
May 3, 2010
Messages
317
Reaction score
12
City, State
On a Round Rock in Texas
Year, Model & Trim Level
2005 Eddie Bauer 2WD.
Seems like it's short cycling, the compressor is cutting on and off more than normal, which could lead to a burned out compressor clutch. Also was oil added when the unit was recharged? As for the noise, some do, some don't. :)
 




rego

Well-Known Member
Joined
December 22, 2007
Messages
187
Reaction score
0
City, State
Mn
Year, Model & Trim Level
98xlt,2000xlt both ohv 6
According to my shop manual, the compressor will cycle more often in cooler ambient temps.
 




4rd Xplora

Elite Explorer
Joined
May 3, 2010
Messages
317
Reaction score
12
City, State
On a Round Rock in Texas
Year, Model & Trim Level
2005 Eddie Bauer 2WD.




my98nnj

Explorer Addict
Joined
September 27, 2008
Messages
1,636
Reaction score
6
City, State
Boonton, New Jersey
Year, Model & Trim Level
1998 XLT
sounds normal to me.
 




Top