hesitation | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

hesitation

bludmon

Member
Joined
January 5, 2009
Messages
45
Reaction score
0
City, State
Hartford,Wisconsin
Year, Model & Trim Level
1998 Ford Explorer
Hi everyone. I have a question about my 1994 Mazda Navajo. I just replaced all of my plugs and wires,my air filter,and my fuel filter. After all that I am still getting a hesitation when the engine is under a load. I even took the IAC off and cleaned it out. Any idea on what could cause this problem? I'm not getting any engine codes either. Any help would be appreciated!
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




<



Roadrunner777

Explorer Addict
Joined
February 5, 2011
Messages
2,030
Reaction score
299
City, State
Bemidji, MN
Year, Model & Trim Level
94 4x4 Sport 88k
I had a lot of hesitation when I was 17 years old too.

yeah, ok... Well, in somewhat random order:

Vacuum leaks definitely, fuel pressure, dirty MAF, clogged cat converter. Stretched accelerator cable (put something on the gas pedal and see if the throttle is wide open). Coil pack less likely, but it's on the list.

History would help too, did it always do this, getting worse? Engine history? Burning oil, loosing coolant? Condition of the plugs that you removed? Could just be the guy's worn out... If you have not done a compression test in a while, I'd do that sooner than later... definitely before I bought significant parts.
 
<



Anime

EF YEAH!!
Elite Explorer
Joined
November 6, 2000
Messages
5,432
Reaction score
38
Year, Model & Trim Level
2018 EX Sport Concept
What brand of wires and plugs? Sometimes low quality parts perform as bad or worse than the worn OE parts. Motorcraft plugs seem to give the best results, though others have replaced with good brands like Bosch and NGK. You might also just have a bad set of wires, or even just a single bad one.

It could definitely be any of the suggestions already listed, though if it only happens under load, my experience is it's usually the ignition or the fuel delivery.

My personal experience was in having hesitation with a loud knock under load, when hitting the gas hard it sounded like a sledge hammer was being pounded against the side of the engine block. Turned out the fuel system was dirty and the injectors/valves were being hampered from flowing the maximum amount of fuel/air from deposits caused by using gasoline with low detergent levels. After switching to using Top Tier gasoline (Chevron. Texaco, Shell, etc.) exclusively, the hesitation ceased after a period of weeks, and has not returned.

You might want to try a bottle of fuel injector cleaner in your next few tanks of gas to really start cleaning the system, but just sticking with Top Tier gas brands is usually enough, though it might take a bit longer to get everything clean on their own.
 
<



<



Tbars4

Moderator Emeritus
Elite In Memoriam
Joined
March 4, 2007
Messages
26,366
Reaction score
69
City, State
anaheim hills,california
Year, Model & Trim Level
95 ranger 4x4/ 91 X 4x4
...Chevron gas is the only one with Techron in it already...Might save you some money there...;)
 
<



bludmon

Member
Joined
January 5, 2009
Messages
45
Reaction score
0
City, State
Hartford,Wisconsin
Year, Model & Trim Level
1998 Ford Explorer
I went ahead and checked the PCV valve and although it rattled when I shoke it I still changed it because it was pretty oiled up and old. Then I put some Seafoam through my brake booster vacuum hose and let it burn out of my exhaust. After that I took it for a ride and it seemed alot better but it did hesitate a couple of times. I think part of the reason this happened is because when I bought it it wasn't running because the starter was junk so it did sit for a good 6 months. What do you guys think. I am actually putting gas in from Shelll that has that nitrogen additive.
 
<



Anime

EF YEAH!!
Elite Explorer
Joined
November 6, 2000
Messages
5,432
Reaction score
38
Year, Model & Trim Level
2018 EX Sport Concept
How long has it been since you bought it? It might take a few weeks or months of good gas and a few oil changes and driving around to clean any fuel/oil/etc gunk or such issues from sitting. Don't drive it so hard that it hesitates, but you might want to hit the gas every now and then.

It'd also be worthwhile in the meantime to check around for any vacuum leaks or holes in the intake system (sometimes the stock air intake tube gets holes melted through on the bottom from the upper coolant hose) and small stuff like that.
 
<



Top