• Register Today It's free! This box and some ads will disappear once registered!

Hi! New to 'Explore'

AeroRamer

Active Member
Joined
July 17, 2008
Messages
89
Reaction score
1
City, State
Jax, FL
Year, Model & Trim Level
'00 Limited
Hi all. New here. I just bought a 'new to me' Explorer. This is my second FORD. The first was a 1989 Ford Escort GT that I used in college back in 1991-1994. Nice fast, little, and fun car back then.

Back to the Explorer. She is a 2000 Limited model with 134,520 miles on it. The color is, I believe, pearl white with goldish accents and interior.

I got her yesterday and gave her a nice foamy bath :D. Looks a little better now. I also replaced the stock air filter for K&N and replaced the antenna for the short rubber type. That is kind of like my calling card when I purchase a 'new' car. Besides that the Explorer is pretty much stock. It is got a Hitch and a Tranny cooler but I am not sure if that is aftermarket equipment or factory/dealer options.

Few items that do not work on her are: cruise control, rear wiper, pass seat heater. I am not sure if the Homelink is working or not. I go through the setup, the lights flash slowly but it does not take the programming. I even tried pressing the learn/training button on the Genie garage opener.

Today I am planning on cleaning the interior and if I have time degrease/clean the engine. After that it will be doing some troubleshooting for the other items.

I hope the Explorer serves me well. It is my replacement for my 1994 Plymouth Voyager SE that just turned 200K yesterday. :thumbsup: But the rebuild tranny, A/C, and other items made me get something else. :( I hate to see it deteriorate. I've had it since 1996 and the OEM tranny lasted me until early this year and I think it was my fault. I started hauling a 5x8 trailer with a couple of motorcycles and did not think of installing a tranny cooler. But maybe it was that time to go independent of the towing. I do not know.

Well, I think this is it for now. I’ll ‘read’ you all online.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




fixxxer

Explorer Addict
Joined
September 28, 2006
Messages
1,457
Reaction score
3
City, State
Aurora, Co.
Year, Model & Trim Level
93 XLT 4X4
Hi and welcome to the forums
 








Sams01XplrSprt

Southern Cali Explorer
Joined
November 14, 2004
Messages
14,231
Reaction score
2
City, State
Newport Beach California & Bay Area California
Year, Model & Trim Level
2001 Sport (sold)
welcome aboard
 








Dopler174

Official Welcome Committe
Moderator Emeritus
Joined
February 21, 2005
Messages
4,999
Reaction score
2
City, State
Greensboro, NC
Year, Model & Trim Level
1993 XLT 4X4
Welcome to Explorer Forum! That is amazing that the Voyager lasted that long.
 




AeroRamer

Active Member
Joined
July 17, 2008
Messages
89
Reaction score
1
City, State
Jax, FL
Year, Model & Trim Level
'00 Limited
Welcome to Explorer Forum! That is amazing that the Voyager lasted that long.

Thanks all.

I know! It was crazy. I got the Voyager used in 1996 with 29k. I like to think that I took good care of her and that I got lucky. First, I replaced the main fluids (motor, tranny, coolant). Then, I replaced the dino motor oil with full synthetic (Mobil 1). And most importantly (I think) was everytime I noticed something marginally wrong or odd I troubleshot it and fix any problems.

Funny thing is that I thought the engine was going to go first. It has been burning oil for a long time but I guess I pushed my luck with the towing.
 








SwampRod

Member
Joined
July 20, 2008
Messages
10
Reaction score
0
City, State
Ohio
Year, Model & Trim Level
2002 Limited
New Today Too

Welcome!
 




Top