• Register Today It's free! This box and some ads will disappear once registered!

High Mount Brake Light Not Working

Zorlack

New Member
Joined
August 9, 2007
Messages
6
Reaction score
0
City, State
San Pablo, CA
Year, Model & Trim Level
Sport Trac 2004 XLT
Hello Forum members :O)

I have a 2004 Explorer Sport Trac and I recently noticed the high mount brake light was out. I removed the bulb and replaced it with a new one, still nothing!!! I checked power to the plug and get nothing, checked fuses everything looks fine. I have cargo lights, and have lower brake lights, tow plug works, any ideas???? :O)
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.








ncranchero

Co-moderator
Elite Explorer
Moderator Emeritus
Joined
August 14, 2004
Messages
3,718
Reaction score
9
City, State
Denver,NC
Year, Model & Trim Level
'94 F150 4x4 SWB 4.9L
On the 2004 model the wiring to the roof runs down the left side, inside, and up the left rear corner of the cab, Look for a light green wire to check for power along that route. It's pin #50 in the main bulkhead connector under the left side of the dash.
 




Zorlack

New Member
Joined
August 9, 2007
Messages
6
Reaction score
0
City, State
San Pablo, CA
Year, Model & Trim Level
Sport Trac 2004 XLT
I now have a funny low beeping when I turn on my left turn signal, it seems to be coming for the flasher relay, could a malfunctioning flasher relay be causing my high brake light to be out? Just curious
 




Pheonixx77

Well-Known Member
Joined
December 14, 2002
Messages
583
Reaction score
0
City, State
NY
Year, Model & Trim Level
02 sport trac
flashers usually don't have anything to do with your third brake light. Did you check the fuses? is there any green powdery stuff on the connectors inside the third brake light assembly? if so take a toothbrush and scrape it off. possibly take an eraser and clean off the terminals.
 




Zorlack

New Member
Joined
August 9, 2007
Messages
6
Reaction score
0
City, State
San Pablo, CA
Year, Model & Trim Level
Sport Trac 2004 XLT
Got it working......

Hmmm can you believe it was a fuse the fuse looked fine but replaced it and it works but one question that high mount only goes on when you step on the brakes correct? It is not supposed to light up when I turn my lights on right? Just checking I don't remember :0)
 




ncranchero

Co-moderator
Elite Explorer
Moderator Emeritus
Joined
August 14, 2004
Messages
3,718
Reaction score
9
City, State
Denver,NC
Year, Model & Trim Level
'94 F150 4x4 SWB 4.9L
Only when you apply the brakes............
 




Pheonixx77

Well-Known Member
Joined
December 14, 2002
Messages
583
Reaction score
0
City, State
NY
Year, Model & Trim Level
02 sport trac
the white lights on it should come on when you have the dome lights on though. or when you open your doors (some trucks)
 




Top