• Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!

    Click Here to start your membership and get rid of the ads!

Horrible CB problems


Ray Hutchinson

Moderator Emeritus
Joined
January 20, 2000
Messages
891
Reaction score
11
City, State
Dana Point, CA
Year, Model & Trim Level
'93 XLT
CB "Squeel"

Peter,

I agree with Stompah, that the problem could be in your microphone, wires, connector, or PTT switch in the mic. Had a CB that squeeled when I squeezed the PTT. Turned out to be a bad switch in the microphone, and I wasn't turning off the reciever when it transmitted, so it was trying to transmit and recieve at the same time resulting in a loud feedback squeel. Luckily I had an old mic. in the junkbox that used the same switch, so I cannibalized the switch, put it the mic. that came with the CB and it now works fine.
 




Peter

Active Member
Joined
December 10, 1999
Messages
319
Reaction score
0
City, State
Virginia
Year, Model & Trim Level
96 XLT
yeh...I originally thought it was the mic also even though it was brand new...I could get it to stop squeeling when I tugged on the wire some..I opened it and re-soldered all the connections and made sure the swithc was working and i thought it was fixed but it still does it, and on top of that i got another mic and have that hooked up and i think it squeels also so either i have two bad mics or I dont know...that is why i am at such a loss!...Thanks, and could it matter much that i have two 10' sections of RG-8(?) connected together with a connector thing instead of having one full 20' section...radioshack didnt have a 20' section so I just put together two when the first 10 didnt reach.
 




Peter

Active Member
Joined
December 10, 1999
Messages
319
Reaction score
0
City, State
Virginia
Year, Model & Trim Level
96 XLT
well its finally over...the answer to all the problems was in the form of 4 20$ bills and a Wilson 1000 antena.........basically in the end with some testing with some guys at a shop...the lowness of the antena on the rear bumper was causing the transmission to get picked up by the mic and thus squeeling...so I got a good strong (please be strong) anntena for the roof and got that feedback problem fixed as for the rest of my install the guy seemed to think there was nothing they could do for the noise anyways, and as long as i am transmitting without squeel thats what I was really concerned about but i checked all my groud points and put in a fuse at the battery and hid my wires better so now I am happy and the truck has a whole new look cause i took off the tire from the roof and cleaned up the apprearence and organized the junk in the back so now all is better...thanks...and at least radioshack took back all their junk that I bought from them!
 




Top