hot drivers side ac and high idle | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

hot drivers side ac and high idle

renzAy34134

Well-Known Member
Joined
September 5, 2008
Messages
357
Reaction score
2
City, State
Fort Myers Florida
Year, Model & Trim Level
2007 Explorer Eddie Bauer
07 x 58k miles, Lately the engine has been revving intermittently during idle. It will idle at 1250rpm then jump to 1750rpm for only 2 seconds then go back to 1250rpm for about 5 seconds then back to revving. this only happens when the air conditioning is on. Also the drivers side AC is not cold. Almost feels as if it is just pulling air from outside and putting it into the cabin without cooling it. The passenger side cools just fine.

My dad said it could be a a/c relay but I just have no idea. It is not throwing codes. Truck drives normal otherwise. If I shut the A/c off the revving goes away. So it is something to do with the a/c just not sure what. Anyone have any ideas?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Do you have the EATC or manual climate control?
 






...? I don't think its manual. it just the 3 knobs that you turn. Its not a digital degree or anything.
 






Then you have the manual. I speculate that the revving at idle might be the AC kicking on and off. The vehicle will automatically do this if the engine is under a heavy load or at higher than normal temps. As for no a/c on the driver side, could be a vacuum line loose. Does it do the same on Max A/C mode?
 






HI

I have the same problem on my 2010 Explorer. Driver side blowing hot air, whilst the passenger and rear works perfectly. High pressure side 324 psi and low side 39 psi. I have dual zone climate control. A/C compressor serviced, oil changed, drier changed etc.

Any help appreciated
 






Then you have the manual. I speculate that the revving at idle might be the AC kicking on and off. The vehicle will automatically do this if the engine is under a heavy load or at higher than normal temps. As for no a/c on the driver side, could be a vacuum line loose. Does it do the same on Max A/C mode?

Yes thats when it does it. It is a normal idle then revvs a little high for about a second than goes back to normal idle for about 2 seconds. It just repeats the process. No extra loads no higher temps. everything seems normal except for the higher engine idle for a second.
 






HI

I have the same problem on my 2010 Explorer. Driver side blowing hot air, whilst the passenger and rear works perfectly. High pressure side 324 psi and low side 39 psi. I have dual zone climate control. A/C compressor serviced, oil changed, drier changed etc.

Any help appreciated

Hi limonigeria. I'm having the same problem on my '07 except it's the passenger side blowing hot. Have you found a fix?

Thanks,
Kyle
 






Back
Top