I need some help diagnosing what this is? | Page 3 | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

I need some help diagnosing what this is?

boominXplorer

Elite Ranger
Elite Explorer
Joined
September 16, 2002
Messages
9,612
Reaction score
1,031
City, State
Virginia Beach, Va
Year, Model & Trim Level
00 4x4 Mounty
That's true. but the scanner had 13 separate items. It could just be doubled. 7 is still a lot to all trigger at once though
7 codes is alot hence why the diag should start at the fuse box and go from there.
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





Alj

New Member
Joined
August 20, 2020
Messages
3
Reaction score
0
City, State
Chesapeake beach
Year, Model & Trim Level
96 ford explorer
I have a 2010 Ford explorer XLT, it has 150k miles. A few weeks ago it started to jerk while driving. Like it would do it 4 or 5 times or until I let off the gas and then it would be drive normally again. Then it started to drop in rpm's in stop and go traffic (From 500ish down to 250 then back up to 500 within 2 or 3 seconds). When I start the car up it would jump up and down in rpms for about a minute then be fine and then when the car warmed up it would randomly do the same. I thought maybe a vacuum leak but both shops I took it to said there wasn't a leak. Now today I was driving to work and a check engine light came on??

So I have a p0455 code with half a tank of gas, rpms jump up and down while sitting at idle and it jerks or lunges while driving. I need help please.
I don’t like for people to throw parts at things but if you’ve checked the basics like coil packs ,plugs etc..A failing Map sensor will cause those issues your describing .O.E.M if ever needing to be replaced
 






Ryan FPIU13

New Member
Joined
March 23, 2022
Messages
6
Reaction score
2
City, State
MN
Year, Model & Trim Level
2013 PIU
It could be a lot of things but I would not go back to anyone that says you need an ECM personally.
 






1Neptune

Member
Joined
April 5, 2020
Messages
33
Reaction score
24
City, State
Chicago IL
Year, Model & Trim Level
2009 Ford Explorer XLT
Forscan is free. Download it to your laptop and plug into your ob2 connector drive while the laptop is in live data mode. Now you will need to bring yourself up to speed on using forscan as well as someone else driving while you are reading the pids. If all of this sounds too daunting for you. Then pay for some diagnostic time locally at a reputable shop. 6 yrs. ago I had to replace my ECM on my '09 . It can and does happen.I agree with the other guy's about look into everything that would affect the fuel trim. Including dirty, failing throttle body.
 






drbenz

Well-Known Member
Joined
July 23, 2011
Messages
207
Reaction score
15
City, State
High Point, NC
Year, Model & Trim Level
2000 EB 5.0
While this is an infrequent issue don't forget that a defective diode in the alternator can cause a LOT of problems now that everything is controlled by a computer. If there is any AC on the normally DC line the poor computer doesnt know if it is a sensor signal or just what and there is no telling what it will do with the "signal" it sees. My old 2000 V8 kept throwing a code for a timing issue in the distributor and when I took the alternator to the starter/alternator shop to get it looked at they told me about folks having trans problems and everything else and all it turned out to be was just a confused computer that can't deal with AC.
 






Joined
April 13, 2022
Messages
35
Reaction score
6
City, State
Portland
Year, Model & Trim Level
07 sport Trac 4.0
Mine threw about 12 codes. I noticed an air leak coming from the EGR so I switched it out. Still heard the air leak. It ended up being the part that the egr bolts to it goes into the plastic intake right after the throttle body I'm currently waiting on the part from Ford so I'll find out if that's where all the codes came from
 






Fix4Dirt

Get a Load O' This Guy!
Elite Explorer
Joined
December 22, 2021
Messages
4,908
Reaction score
3,522
City, State
Los Angeles, CA
Year, Model & Trim Level
1998 XLT 4x4
Mine threw about 12 codes. I noticed an air leak coming from the EGR so I switched it out. Still heard the air leak. It ended up being the part that the egr bolts to it goes into the plastic intake right after the throttle body I'm currently waiting on the part from Ford so I'll find out if that's where all the codes came from
my egr o ring leaked, but it never threw codes for me. those things are a pain!! out of curiosity, which codes did it throw? were they consistent with what OP describes?
 






Jacky12

Member
Joined
April 10, 2022
Messages
17
Reaction score
7
City, State
Nashville,TN
Year, Model & Trim Level
2010, Ford Explorer, XLT
Add stalling to my list of issues now. holy heck. I'm replacing the EGR and Map sensors today - Hope the o2's clear after the EGR. Also taking it to a shop to get live testing done tomorrow if they don't clear today.

Drbenz - If I had my alternator tested what would I be looking for?
 






Fix4Dirt

Get a Load O' This Guy!
Elite Explorer
Joined
December 22, 2021
Messages
4,908
Reaction score
3,522
City, State
Los Angeles, CA
Year, Model & Trim Level
1998 XLT 4x4
if the o2s are too out of whack i suppose it could cause a stalling issue. or a stupidly large vac leak and it cant compensate for the extra air, even when dumping fuel.
 






Joined
April 13, 2022
Messages
35
Reaction score
6
City, State
Portland
Year, Model & Trim Level
07 sport Trac 4.0
I just put the new part on and ugh 😫 it's still leaking air. I spray the carb cleaner right on where the EGR meets the tube connector and it almost stalls it out I'm 🤔 any ideas?
 






Joined
April 13, 2022
Messages
35
Reaction score
6
City, State
Portland
Year, Model & Trim Level
07 sport Trac 4.0
my egr o ring leaked, but it never threw codes for me. those things are a pain!! out of curiosity, which codes did it throw? were they consistent with what OP describes?
I didn't get to see the codes. I went to have the 3 cleared when I fixed the cats he just cleared them and said there was 12. But I also think I'm having the bad wiring issue also so could be that but I did go threw and repair what I could see
 






Fix4Dirt

Get a Load O' This Guy!
Elite Explorer
Joined
December 22, 2021
Messages
4,908
Reaction score
3,522
City, State
Los Angeles, CA
Year, Model & Trim Level
1998 XLT 4x4
I just put the new part on and ugh 😫 it's still leaking air. I spray the carb cleaner right on where the EGR meets the tube connector and it almost stalls it out I'm 🤔 any ideas?
how bout the upper intake gaskets? crack in the intake itself?
 






jr230

Well-Known Member
Joined
December 2, 2018
Messages
114
Reaction score
52
City, State
cape coral
Year, Model & Trim Level
2004 explorer xlt..
Callsign
n3nai
I don’t like for people to throw parts at things but if you’ve checked the basics like coil packs ,plugs etc..A failing Map sensor will cause those issues your describing .O.E.M if ever needing to be replaced

I have a 2010 Ford explorer XLT, it has 150k miles. A few weeks ago it started to jerk while driving. Like it would do it 4 or 5 times or until I let off the gas and then it would be drive normally again. Then it started to drop in rpm's in stop and go traffic (From 500ish down to 250 then back up to 500 within 2 or 3 seconds). When I start the car up it would jump up and down in rpms for about a minute then be fine and then when the car warmed up it would randomly do the same. I thought maybe a vacuum leak but both shops I took it to said there wasn't a leak. Now today I was driving to work and a check engine light came on??

So I have a p0455 code with half a tank of gas, rpms jump up and down while sitting at idle and it jerks or lunges while driving. I need help please.
sounds similar that my 04 4l sohc was doing then it would stall whe drive about 3-4 miles warm weather. it was the fuel rail sensor
got on amazon 18 bucks local auto discounts wanted around 150 my mobile mechanic is a club member so we replaced it supposed fix was remove the manifold cover but when he unbolted the hoses and the drivers side he was able to just lift it enough to get it changed it worked so now gasket to change at 150 if you havent done fuel pump its probably due and in my 99 had to drop tank of course i had a full load of gas
 






Jacky12

Member
Joined
April 10, 2022
Messages
17
Reaction score
7
City, State
Nashville,TN
Year, Model & Trim Level
2010, Ford Explorer, XLT
Sorry for not replying for a week. So I replaced my MAP and EGR sensor last week and nothing changed so I went ahead and ordered a used ECM and had it programed/installed this Friday and so far after 100+ miles its driving perfect. I hope I didn't jinx it lol but yeah it seems to have been my ECM causing the issues. Thank you all for your advice and help it was much appreciated.
 






Top