Info-Setup-Reset no longer works | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Info-Setup-Reset no longer works


New Member
November 8, 2017
Reaction score
City, State
Mid Michigan
Year, Model & Trim Level
08 Mountaineer Premier V8
I have a 2008 Mercury Mountaineer that I was investigating replacing the radio. I took apart the dash bezel, and unplugged all the connections. I reinstalled and everything worked fine. I then took it apart again, and when I connected it again, the Info, Setup and Reset buttons no longer function. I've unplugged and re-plugged several times, and it still doesn't work. I've checked the pins, and they are all straight and appear to be making a good connection. I've also disconnected the battery and reconnected it, and still nothing. Is there some type of reset sequence that needs to be performed to make it work?

Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!

So the message centre in the dash doesn't function?

Does the message centre switch (what you are referring too) have a 4 wire connector?

Correct. The only thing that displays is the miles/odometer. There are 4 pins on the back of the switches, but the connector actually has 6 wires going to it (there are 8 holes total), even though only four are used. When the vehicle lights are on, the switches light up, so I'm confident that the plug is seated.

I have all the service manuals for a 2006 Explorer/Mountaineer. So there may be a difference in the wiring from 2006 to 2008, but I will relay the info from the 06 wiring diagrams in hope that it may be of help.
Pin #1 is a blue w/brown stripe wire for cluster and panel illumination.
Pin #2 is green w/blue stripe to instrument cluster. (analog ground)
Pin #3 is green w/violet stripe to instrument cluster. (message centre+)
Pin #4 is black w/white stripe to ground(. G200)

Pins 1 & 2 are spliced to other switches, sensors etc along their lengths.

Will post any other info that I may find.

Thanks for the wiring info. As I read through it, I realized that there were 6 wires in the plug, not the 4 that you mentioned. After following the wires back into the harness, I came across another plug that only had 4 wires, and the colors matched up. I realized that i had the wrong plug plugged in! The 6 wire plug is supposed to go to the other side where the 4 wheel drive controls are on the Explorer. Because the Mountaineer doesn't have those switches, the 6 wire plug is unused, even though it fits in the same slot. Once I plugged in the 4 wire harness, everything worked great. Problem solved!