interesting things happening that shouldn't | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

interesting things happening that shouldn't

Bootless

Well-Known Member
Joined
December 25, 2015
Messages
242
Reaction score
5
Year, Model & Trim Level
1994 ford explorer 4x4
Ok guys just git done doing valve cover egr uper intake iacv and throttle body gaskets and new plugs now its missing a little and if I let it idle for more than 30 seconds it just dies and some time back fires when I press the gas some one please help me
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





OneofMany

Well-Known Member
Joined
December 21, 2012
Messages
225
Reaction score
4
City, State
Georgia Mountains- Talullah Falls
Year, Model & Trim Level
94 expl 4x4
fix what u messed up.
 






Centaurious

Well-Known Member
Joined
April 28, 2015
Messages
433
Reaction score
127
City, State
Pensacola FL
Year, Model & Trim Level
1994 Explorer Sport
A. Check the spark plugs to make sure that they are actually tight and not the socket binding up in the plug hole. Ensure that the plug wires are fully on the plugs.
B. Make sure that the firing order is correct with regards to the coil pack. Backfiring is almost always ignition caused and you messed with the plug wires and the connector to the coil pack.

Good Luck
 






chefduane

Texas Elite Explorer
Elite Explorer
Joined
January 22, 2013
Messages
1,341
Reaction score
77
Location
TEXAS!
City, State
Plano, TX.
Year, Model & Trim Level
None: SOLD 9/16
B. Make sure that the firing order is correct with regards to the coil pack. Backfiring is almost always ignition caused and you messed with the plug wires and the connector to the coil pack.

^ This.
 






Bootless

Well-Known Member
Joined
December 25, 2015
Messages
242
Reaction score
5
Year, Model & Trim Level
1994 ford explorer 4x4
Ok guys thank you when I took it apart I checked passenger side it was 123 so I figured driver would be the same I just got a diagram from here and it had 3 wires hooked up wrong runs great now
 












Top