Intermittent engine light | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Intermittent engine light

MarkNM

New Member
Joined
September 10, 2012
Messages
6
Reaction score
0
City, State
Santa Fe, NM
Year, Model & Trim Level
'93 & '02 XLT
Got a 93 xlt. The CEL comes on usually after it has sat awhile then goes out when rpms reach 2500 then stays out until I stop the car again, seems to come on when trans shifts to 2nd then out when shifts to 3rd.
I got an actron code reader but my truck seems to be missing the single pigtail wire for the connection. I hooked up the reader any way to see what it would do. Whether I try KOEO or KOER tests I get the same output looked like 16 or 133, hard to tell if there was a pause at 3 flashes makes me lean toward 16.
Any ideas?
 




awood

Well-Known Member
Joined
February 15, 2006
Messages
274
Reaction score
0
City, State
Kaysville, utah
Year, Model & Trim Level
94 XLT
Hmmm, something doesn't seem quite right there.

Make sure you're on the correct connector. There's an ABS test port on the drivers side fender not far from the windshield washer reservoir. The EEC test port (the one you want) is on the passenger side between the air filter housing and the blower motor...at least that's where it is on my 94. The two test ports are similar. My ABS test port is red. The EEC port is black with a gray pigtail nearby.

Also, for some dumb reason I have always used an analog volt meter to read my codes. There's an initial code (fast codes) that you may be interpreting as a "1", when in reality it's not useful for your test - you just gotta know it's there. Then if you have no hard codes, you will get a 111 code which is repeated once. I'm wondering if you're interpreting the fast code and two sets of 3 as the "16" or the 133?

Remember, beyond the hard codes is the CM (continuous memory) codes. But if you have none, nothing will show. Beyond that is the KOER test which is quite a different animal. That is done with the engine running. There are some very good guides online to do the 3 different tests. It's not exactly easy if you've never done it before.
 




Top