Jerk in motion in Explorer 2011 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Jerk in motion in Explorer 2011

Ford2011

New Member
Joined
December 30, 2014
Messages
1
Reaction score
0
City, State
Qatar
Year, Model & Trim Level
2011 explorer
Hi friends, I brought Ford explorer 2011 from Ford pre-owned show room recently. When I brought from show room, i have confirmed from sales person about vehicle condition and services history, they confirmed all are good including service history. Unfortunately after couples of months, I am facing strange issue i.e. like jerk in motion. Actually when i am going constant speed, then no issue. whenever we apply brake and bring down to 20 -30 and accelerate immediately from that speed, then vehicle is experiencing some sort of jerk. I dont understand, when i approach show room, initially it could happen due to spark plug or fuel filter. After replacing them, issue is remain. Kindly suggest me what could be issue. Is this issue common in most of vehicle ?

your suggestion is highly appreciated.

Thanks
 
<



jrmexplorer

Explorer Addict
Joined
April 19, 2011
Messages
1,109
Reaction score
3
Year, Model & Trim Level
2011 Limited
I believe what you are experiencing is covered by a technical service bulletin (TSB). The TSB has the transmission reprogrammed. I don't have the TSB handy, but if you do a search on these forums you'll find it. I experienced something similar and the TSB fixed it.
 
<



Top