Jon And Sheri's Vitamin D Wagon | Page 18 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Jon And Sheri's Vitamin D Wagon

As she sits now,
017.jpg

019.jpg


015.jpg


013.jpg



018.jpg


But it didn't start out like this.




We returned from our trip to Colorado Sept 2009 to find this waiting in the yard.

It needs a few little sumthuns--but it is a great start I do think.
Here is where we begin to take over the work started by trukmajik and dejello



94explorer001.jpg


94explorer003.jpg


94explorer002.jpg


94explorer004.jpg


94explorer007.jpg


94explorer006.jpg


94explorer005.jpg


9-11-2009092.jpg


9-11-2009090.jpg



updated pics ^^^^^how it was when I got it

Now here is how it looks as of 4-1-2010

got the wheels all shiny!

truck002.jpg


frostbite001.jpg


truck001.jpg


truck006.jpg


truck005.jpg


truck004.jpg


truck003.jpg


and as of 8-5-2010

IMG_1105.jpg

with swaybar^^^

without sway bar

IMG_1064.jpg


IMG_1061.jpg


revised shock towers and more flex-Big thanks to Dkchrist for coming over to weld em in. I owe him big time!!

IMG_1905.jpg


IMG_1903.jpg


With a top

IMG_1988.jpg


IMG_1986.jpg


IMG_1983.jpg


LED rock lights

IMG_1925.jpg
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





It blends in with a bigger bundle which goes down the fender well, then trough the frame rail. It looks like it continues along the inside of the frame rail, behind the ABS valve cover and to the ******** gas tank??

One pic is looking up the back side of the fender well, the other is the inside of the frame rail
 

Attachments

  • IMG_2539.jpg
    IMG_2539.jpg
    60.6 KB · Views: 1,319
  • IMG_2540.jpg
    IMG_2540.jpg
    55.1 KB · Views: 1,306



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.











Albino the picture helped tremendously.

Thanks!!
I found the hidden harness by looking at it, then went outside and sure enough mine was hidden down inside the frame rail. I plugged in the 2-( yes 2 ) connectors, hit the key on and the pump ran. So, I bumped the starter, the engine fired right up and the fan sucked Mark's drop light into the alternator pulley, ripping the wires from it and thus throwing a breaker. I'll fix the light later.:D

Now I need to hook up the maf and intake, see how this puppy runs!
 












Albino the picture helped tremendously.

Thanks!!
I found the hidden harness by looking at it, then went outside and sure enough mine was hidden down inside the frame rail. I plugged in the 2-( yes 2 ) connectors, hit the key on and the pump ran. So, I bumped the starter, the engine fired right up and the fan sucked Mark's drop light into the alternator pulley, ripping the wires from it and thus throwing a breaker. I'll fix the light later.:D

Now I need to hook up the maf and intake, see how this puppy runs!

Got a little excited, eh Jon?????
 






Now I need to hook up the maf and intake, see how this puppy runs!

tictoc, tictoc.

Hmm must be running and he is out terrorising the neighborhood???
 






























Party time!!!

Now you need seat heaters ;)
 


















Damn it it's snowing here again too :frustrate:frustrate:frustrate

I wouldn't mind but I have to drive to work in it in the morning.

Glad you got that thing running Jon.
 






Hey congrats JT - and congrats on the snow :)
 






Nice job Jon! :thumbsup: You'd think you'd motivate me to get to work, but you don't. Could you just come out here and work on my truck for me? :D
 






Congrats on getting it running, are those powder coated rims already?
 












NICE NICE NICE!!!!!!!!!!!

so you like Gen I's yet?
LOL
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





If it wasn't for all you guys helping out, I would have thrown it out-:D


I deeply appreciate it.

Kert, no powder yet. I was just trying to get this thing moving so I could tell what needed worked on. Believe me, there is a honey do list as long as the truck is.

And Danny, yes I needed this bad.

The truck runs awesome. It did throw a check engine light as I pulled it back in, and the "BRAKE" light is illuminated.

The steering wheel is either bent, or is just sitting at a goofy angle-maybe it is just me, but it seems to be " mounted" at an angle--as in the steering column seems to be pointed to the right-idunno.

There is also a "whom whom whom" sound like an out of round tire-bent axle sumthing.
The front is leaking, and I need to replace the steering links-I want the pitman arm link to go to the right knuckle, then a drag link from knuckle to knuckle-
as it is, the steering link is attached to the drag link, and it moves up and down a bit ( drag link rotates) before the steering goes side to side. I do not like that
 






Back
Top