Just bought PIU - surging rpm ? | Page 3 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Just bought PIU - surging rpm ?

N4YLOR

Member
Joined
May 7, 2017
Messages
21
Reaction score
7
City, State
Maine
Year, Model & Trim Level
2013 Ford P.I.U. 3.7L
Low speed surging fixed! got under vehicle, drained out 4+ qts of trans fluid & replaced drain plug. Replaced fluid along with 1 tube of "Dr. Trannys shudder stop". Vehicle feels like new. Absolutely no surging, It was so bad before I did this that I didnt enjoy driving the vehicle in town because of the lower speed surge. Now I love it. Just wanted to share my experience with the "Surge" Thanks

It’s definitely a night and day difference. Glad it worked out for you.
 
<

Join the Elite Explorers $20 Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,989
Reaction score
2,526
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Low speed surging fixed! got under vehicle, drained out 4+ qts of trans fluid & replaced drain plug. Replaced fluid along with 1 tube of "Dr. Trannys shudder stop". Vehicle feels like new. Absolutely no surging, It was so bad before I did this that I didnt enjoy driving the vehicle in town because of the lower speed surge. Now I love it. Just wanted to share my experience with the "Surge" Thanks
Welcome to the Forum Mike.:wave:
Thanks for the post/info.

Peter
 
<



Swoop913

New Member
Joined
February 12, 2019
Messages
1
Reaction score
0
City, State
Belding, Mi
Year, Model & Trim Level
2014 PIU 3.7
Hopefully this helps me. I have the exact same issue right now and I haven't had the vehicle for a week yet. I'm also having a hard time trying to find a service/repair manual for it since it wasn't a public option engine.
 
<



peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,989
Reaction score
2,526
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Welcome to the Forum.:wave:

Peter
 
<



16vcabman

Member
Joined
February 25, 2020
Messages
46
Reaction score
7
City, State
Ortonville
Year, Model & Trim Level
2014 piu
Change fluid ! Makes that issue disappear . Pretty sure it’s just a fluid issue
I have a14 doing this also with only 77,000 miles. It been driving me nuts. Going to try drop the pan and refill. Keep your fingers crossed for me?!!
 
<



16vcabman

Member
Joined
February 25, 2020
Messages
46
Reaction score
7
City, State
Ortonville
Year, Model & Trim Level
2014 piu
Fluid is depleted of the property that deals with shudder. Change fluid, takes about 5.5 quarts of mercon lv. I used some universal from Walmart. About 18 a gallon. While there get that trans funnel that has the flexible hose end on it. Took me about a half hour to drain from small plug on bottom of trans and refill. I also be added some lube guard anti shudder fixx to it. Drives beautiful now. All the anxiety of trans rebuild and just a fluid change. I don't believe in flushing a trans because it reverses the flow and breaks loose crud in the torque converter, this can get back into things such as valve body and hurt an otherwise good transmission.
 
<



Cedlins

New Member
Joined
November 10, 2021
Messages
3
Reaction score
0
City, State
Fort Lauderdale
Year, Model & Trim Level
2015 Ford PIU
Hi its CedTheProwler
I have a 2015 ford fpiu 3.7L
bought @ roughly 68,000miles now @ 78,289
Man I've been gunning this issue down for a few weeks ughh.....
This symptom replicates a faulty MAF , throttle body , coils, plug you know where I'm going
I noticed the issue start to get worse about 1 week ago > current 11/10/21. and when the temp reaches it highest point .like driving in city or HWY
I'll tell you what I've done so far Changed spark plug, cleaned MAF and Throttle body , changed EVAP purge valve,
and also pvc valve.
none of that worked......

Mind you now after doing all this , one day it hit me maybe the transmission needs maintenance!!!
This morning i went to ford @7:30 am to grab merconLV 5 quarts tranny fluid and a radiator cap only cause i need a new one but besides that i did the fluid change myself .
took out the plug for transmission using a 11mm and let drain fluid was mad dark. its a really easy job guys and i believe it solved the problem
it gave me amazing results what i was looking for .... stops the shuddering under low acceleration

(Keep in mind) I only did a fluid change not a FLUSH
after fluid change i did noticed a light shudder sometimes but it wayyyy better than before so that lets me know that the old fluid lost its working properties.
LOL its barley noticeable tho now when its does occurs its like car is being tickled just a bit

but man fluid change is defiantly required don't hesitate guys to change it !!


I know you guys mentioned you did a flush but i wanted to save money $$$ and probably do another fluid change in about 1,500 miles to get the remainder of the older fluid out of there
 
<



peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
31,989
Reaction score
2,526
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
^^Welcome to the Forum Ced. :wave:

Peter
 
<



<



Cedlins

New Member
Joined
November 10, 2021
Messages
3
Reaction score
0
City, State
Fort Lauderdale
Year, Model & Trim Level
2015 Ford PIU
UPDATE ALERT :

Hey Guys so I noticed after a few days issues still here ughh.
something told to connect my cheap Walmart OBD scanner into the car once again .
NO Check engine light but pending code P0113 IAT volts too high

i hate to find out the throttle bod is bad cause the aren't cheap
I've seen a video where the guy was explaining how a gas pedal sensor can go bad providing a incorrect readings to throttle body

the car is a used cop car so i thinking maybe i have bad gas pedal
someone near e was parting out and i found a explorer wth 56,000 mile and bought the original gas pedal for 20$, installed over weekend and haven't had ANY ANY hesitation whatsoever. been driving a few days and it runs perfect

check your gas pedal peeps!!
 
<



Top