KKM Problems | Page 2 | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

KKM Problems

Post a pic or two of your intake manifols; it has to be there.

Good luck ....
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





I did unplug the battery for about 25 minutes, but did not take it for a drive as I was in a hurry to get to work, and did not want to have problems on the way there. Another problem I had was with the support bracket. The pictures sent to me show the intake tube coming from over the radiator, mine comes almost directly from the firewall and the support bracket does reach any surface so I am afraid it will bounce around too much and cause some damage.
 






here's the pics... not the best pics in the world but its the only camera I had handy today.

1.jpg



2.jpg



3.jpg



4.jpg



5.jpg



6.jpg
 






2004-2005 with throttle by wire do not have a IAC. It is a part of the whole throttle assembly now.

Every open air filter kit I have ever seen has whistled at wide open or close to wide open throttle. Thus the reason the original filter had a silencer that went into the fender or front facia. When air moves at hi velocity through a restriction, a whooshing or whistling is going to happen. It may be minimized by design, but it can still be present.
 












2004-2005 with throttle by wire do not have a IAC. It is a part of the whole throttle assembly now.

Every open air filter kit I have ever seen has whistled at wide open or close to wide open throttle. Thus the reason the original filter had a silencer that went into the fender or front facia. When air moves at hi velocity through a restriction, a whooshing or whistling is going to happen. It may be minimized by design, but it can still be present.


It seems like the whine/noise is only at about 1/3 throttle. I can throttle "through" it at will. At WOT there is a hiss/woosh noise which is normal of aftermarket intakes...
 






It seems like the whine/noise is only at about 1/3 throttle. I can throttle "through" it at will. At WOT there is a hiss/woosh noise which is normal of aftermarket intakes...

You might try unhooking the crankcase vent line that runs from the valve cover near the oil filler kneck and plug the line that runs to the intake pipe with a bolt and go for a quick spin. This will allow the valve cover to vent direct to the atmosphere, for which if it is the source of the noise, should become louder or change to a different range. We had an issue with a few Rangers in the past that did something similar, so when we determined the source, we restricted the line slightly which eliminated the sound.
 






Every open air filter kit I have ever seen has whistled at wide open or close to wide open throttle. Thus the reason the original filter had a silencer that went into the fender or front facia. When air moves at hi velocity through a restriction, a whooshing or whistling is going to happen. It may be minimized by design, but it can still be present.

What he said, I tried two different kits, and installed a new IAC. It still make that whistle screeching sound. I'm back to stock with a K&N panel filter and that air horn thing removed from the front of the stock filter box. I wanted to try the KKM kit too, but I'm cutting my losses while I'm ahead.
 






Back
Top