Lifter question | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

Lifter question

DR264

Member
Joined
October 10, 2000
Messages
27
Reaction score
0
City, State
Peoria, IL
Year, Model & Trim Level
93 XL, 96 XLT
I have a 93 with 115k. When i start it, it will tick, tick, tick, and then stop for a second and then start ticking again. Usually does this until it warms up. I just changed the oil and put in 20w-50, thinking it would quiet it down. Wrong, it made it worse. The ticking doesn't go away. I'm thinking sticky lifter? Any help would be appreciated.

Thanks, Dustin
 
<



olivesman

Well-Known Member
Joined
September 6, 2000
Messages
374
Reaction score
0
City, State
Fayetteville, Georgia
Year, Model & Trim Level
'91 Eddie '91 Sport
ah man, i JUST got on here to start a thread about the same exact thing. what is wrong w/ my motor????! i know someone out there must have had this problem and knows the solution. who can help, please?


the ticking also accelerates w/ the motor's RPM's.

thanks a lot-russel
 
<



SteveVB

Elite Explorer
Joined
July 8, 1999
Messages
2,525
Reaction score
3
City, State
Gaithersburg, Maryland
Year, Model & Trim Level
04 Rubicon w/stuff
The lifters are a problem on the 4.0 usually need attention in the 85-100k range. Use thinnner oil may help, or a flush, but most likely the lifter itself is bad and needs replaced. Do a search plenty of hits will show up.

Stevens Parts Dead Link Removed in Tx and Vanir have take outs much cheaper than the dealer.
 
<



blinkgi

Member
Joined
April 1, 2001
Messages
22
Reaction score
0
City, State
Oxnard, CA
Year, Model & Trim Level
1991 sport
lifter

I just put new gaskets on my 91 sport and foud that on one of the lifters ( they are roller lifters) was missing a little cotter key. I thought nothing of it and just put it back together(VERY STUPID, DO NOT DO THIS!!!). Now I have to take apart again, because the lifter ticks until it warms. So I think that your problem has to do with the same thing, theey get old and the key falls out or something
 
<



Top