Lighting Issue | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Lighting Issue

Lee7238

Member
Joined
February 25, 2018
Messages
12
Reaction score
1
Year, Model & Trim Level
1999, Sport 2WD, SOHC
Hello,

I'm having trouble finding the correct headlight switch connector.

The pictures below are the old connector, the little terminals themselves and the headlight switch. The second picture is what comes up when I search for a new one, but it doesn't look like it will fit. Any assistance would be greatly appreciated. I've used this great forum a few times. Thank you.

1999 Explorer 2WD 4.0L MFI SOHC 6cyl

upload_2018-2-25_16-33-52.png


upload_2018-2-25_16-26-19.png
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





I must not be understanding what you mean because the bottom pictured connector looks to me like it should fit the top right pictured connector, assuming that the two horizontal brass pieces in the top right pic are only present at the base of the socket, not sticking up like the other contacts in it.
 












You were right, it fits. The only problem I'm having now, is the one I got has 11 wires but there are only 8 in the vehicle. I know the bottom two match up but I don't know what to do from there. Thank you.
 






You'd wire the pins on the new connector based on the wires/colors used on the old one. Anything unused you can just wire tie out of the way, though if the unused ones still get some power feed back from the switch, insulate them from each other and ground.
 






Sorry for the late thank you, but thank you.
 






Back
Top