Look ma, no lights! | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!
    If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Look ma, no lights!

dano126

New Member
Joined
September 16, 2011
Messages
1
Reaction score
0
City, State
Tiffin, Ohio
Year, Model & Trim Level
2005 Ford Expedition Ltd
A friend brought his 2001 Explorer Sport to me, stating his headlights and fog lights do not work. The high beams work on "flash to pass", but thats it. Check all the fuses, then found out about the LOM...which we then pulled the center console to find...NOTHING. I've been doing some searches on this, finding that a lot of people are saying that the location of the LOM is under that center area for 1998 to 2001 Explorers...but not ours. Anybody got anything else for me to check besides the obvious, (multifunction switch and headlight switch)?
thanks for any help
dano126
 






DjDom

Moderator Emeritus
Joined
September 11, 2011
Messages
2,609
Reaction score
6
City, State
Toronto, Ontario
Year, Model & Trim Level
97 XL(imited)
I hope you checked fuses/relays..
There's a fuse box just to the right of the gas pedal. It's hidden up there. I know one relay there is for the headlights.
Also, there's a fuse box under the air filter. There's a fog light relay there.
The other 2 fuse boxes you probably know of. Left side of dash and under hood near brake booster.
 






Top