• Register Today It's free! This box and some ads will disappear once registered!

Loud humming noise coming from the air filter

S

scubaman

I have a 95 Explorer and I'm getting a loud humming noise coming (it seems) from air filter compartment. I took it in for repair but they could not figure out what was causing the sound. Any ideas? I'm trying to avoid taking it to the dealer!! ($$$). It does do it all the time and it doesn't affect my engine, steering or braking. Please help me solve this problem because it's getting on my nerves.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




KyleC

Active Member
Joined
September 17, 1999
Messages
90
Reaction score
0
I dont know if this helps but a friend of mine has a F-150 that was doing this because he drilled holes in the airbox and weakened the plastic just enough to make it resonate as the air goes throught it. It actually sounds like a cow mooing at certain RPMs.
 




Chris Suerig

New Member
Joined
October 6, 1999
Messages
2
Reaction score
0
I have the same problem with my 97. Did you ever find the problem? my e - mail is Csuerig@aol.com. Thank you.
 




rwp99exp

Member
Joined
August 8, 2004
Messages
10
Reaction score
0
City, State
el cajon, ca.
Year, Model & Trim Level
1999 explorer sport
mine does the same thing and i have the gen 1 K&N. they say it normal.....its just sucking a lot of air
 




Alec

Elite Moderator
Moderator Emeritus
Joined
April 25, 2000
Messages
15,997
Reaction score
1
City, State
Houston, Texas
Year, Model & Trim Level
2008 JK
Very loud humming noise at idle (or low load) = IAC, Idle Air Control valve. A zillion posts on here about it, good luck!
 




unclemeat

Explorer Addict
Joined
October 20, 2002
Messages
3,079
Reaction score
4
City, State
Richmond, VA
Year, Model & Trim Level
91 sport
It is also cheap and simple to fix.
 




My98xplorer

Well-Known Member
Joined
July 28, 2004
Messages
108
Reaction score
0
City, State
lakeland fl
Year, Model & Trim Level
1998 Sport
I had the same problem with my Explorer. It was indeed the IAC, i took it off and cleaned it out and instantly no more humming!
 




fordfordboy

New Member
Joined
March 30, 2008
Messages
1
Reaction score
0
City, State
texas
Year, Model & Trim Level
95 explorer
humming noise!

The humming noise on my 95 explorer started after I instaled a K&N filter. It only does it at idle, not when i hit the gas. And it starts right about when it hits around 90 degrees outside. I will look at the control valve.
 




SuperSix1

Member
Joined
April 20, 2009
Messages
10
Reaction score
1
Year, Model & Trim Level
1997 XLT
I just got my car back had the serp belts replaced some other things + a long overdue air filter/ oil change and my cars been humming in the low rpms at stop lights but never while on the highway/ constant moving ... I figure its just sucking alot of air in...
 




ugoguyo

New Member
Joined
December 25, 2013
Messages
1
Reaction score
0
City, State
west covina , california
Year, Model & Trim Level
1998 ford explorer
Ive had that same humming from my air filter box for about 5 years ....Its annoying!! ...its time to fix it
 




Top