low RPM sputter | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

low RPM sputter

SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
Just got this 88 BII, It needs a little bit of work to get going back at 100%
But first thing I need to get out of the way is when its at low rpm, (starting at a light) or whatnot it sputters, like cuts in and out. It does not die out but cuts out. Should I change the plugs and wires first?
 




rookieshooter

Moderator Emeritus
Joined
March 13, 2005
Messages
7,290
Reaction score
1
City, State
Martinsburg WV
Year, Model & Trim Level
84 BII "Li'l Samson"
SBJ420 said:
Just got this 88 BII, It needs a little bit of work to get going back at 100%
But first thing I need to get out of the way is when its at low rpm, (starting at a light) or whatnot it sputters, like cuts in and out. It does not die out but cuts out. Should I change the plugs and wires first?

That's a good starting point with plugs and wires. Take out some plugs and read the condition of them. Fouled, gap to large etc. Spark plug wires are often overlooked and really can make an engine come to life when replaced with plugs. If you have a multimeter you can check the ohm readings of the wires. May be a fuel distribution thing also. I know on some of my carbed engines. That sputtering was sometimes due to a bad throttle pump that did not give that initial burst of gas down the venturi. But as the engine developed vacume it would work fine.
 




SBJ420

Well-Known Member
Joined
June 12, 2006
Messages
443
Reaction score
0
City, State
Windsor NS
Year, Model & Trim Level
95 XLT
it also has a little bit of a gas smell comming from it. but no leaks. At lunch today it actually died right out. Could this be the fuel filter? Just trying to get all options done for when I go home and go at this thing. So it cuts out at low rpm.
 




Top