Low voltage warning on startup | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

Low voltage warning on startup

5 string

Member
Joined
December 9, 2013
Messages
15
Reaction score
0
Year, Model & Trim Level
2017 Explorer Sport
2014 Explorer Sport 29k mi. purchased late January 2014.

My Explorer MFT turned a few days ago and displayed "Low power, shutting down" or something along those lines and was *slightly* hesitant during engine start. There are no voltage warnings on info displays and the phyiscial battery window indicator is green.

Drove it for quite some time afterwards to charge, just in case, then placed on a battery tender charger overnight, each night since onset.

If it is the battery, is it still under warranty, or is it a pro-rated deal? Anyone have/had a similar issue?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





2014 Explorer Sport 29k mi. purchased late January 2014.

My Explorer MFT turned a few days ago and displayed "Low power, shutting down" or something along those lines and was *slightly* hesitant during engine start. There are no voltage warnings on info displays and the phyiscial battery window indicator is green.

Drove it for quite some time afterwards to charge, just in case, then placed on a battery tender charger overnight, each night since onset.

If it is the battery, is it still under warranty, or is it a pro-rated deal? Anyone have/had a similar issue?

Hurry and take it in. It's under warranty.
 


















Battery replaced under warranty. No other issues found. Thanks!
 






That green bit on the batteries doesn't mean much.

mostly that the fluid level is still up doesn't mean the electrolyte is actually good - or there isn't a bent, cracked plate or shorted cell.

ALso yes you can have a shorted cell and the battery still read 12V with no load.
 






Back
Top