• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

Lukewarm heat from all vents 2004 Explorer

mbundy1

New Member
Joined
January 16, 2013
Messages
4
Reaction score
0
Year, Model & Trim Level
2004 Explorer Eddie Bauer
Hi,

I have a 2004 Explorer Eddie Bauer V8 with dual climate temperature control. So far in the past year I've had the transmission and heater core replaced (still on warranty) and the radiator replaced recently. When I turned the car on I would hear a loud thud coming from behind the dash and then the heat would turn on. However, now I no longer hear the thud, the last time I hear the thud it sounded like plastic breaking and falling down, but I only get lukewarm air from all the vents (driver, passenger, back seats, and front defrost).

I am not sure what the problem is. I have looked into the Blend door actuator but I find it hard to believe that both actuator's failed at the same time. If it's the blend doors, how are they both broken at the same time?

Or could there be any other problems that my google search skills have failed me with that starts with a thud and ends with a lack of heat?

Thanks for the help.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




thepotroast

Well-Known Member
Joined
February 24, 2009
Messages
1,065
Reaction score
5
City, State
Asheville, NC
Year, Model & Trim Level
3rd Gen EB 4x4 V8




mbundy1

New Member
Joined
January 16, 2013
Messages
4
Reaction score
0
Year, Model & Trim Level
2004 Explorer Eddie Bauer
I have read that post. It looks like it is for the manual climate control systems and not the automatic dual control systems. From my understanding the dual control systems have 2 actuators and it is highly unlikely that both broke at the same time.

Since I have no heat from any vents I'm thinking it may be a different problem.

If I am wrong please let me know.
 




rrgone

Active Member
Joined
July 9, 2006
Messages
770
Reaction score
5
City, State
Tucson, AZ
Year, Model & Trim Level
'02 XLT
Here are some possibilities:

  • Low coolant.
  • Air pocket in coolant.
  • Thermostat stuck open.
  • Heater core bypass valve stuck closed.

I am with you that it's not likely caused by blend doors failing together.
 




mbundy1

New Member
Joined
January 16, 2013
Messages
4
Reaction score
0
Year, Model & Trim Level
2004 Explorer Eddie Bauer
Would any of those have caused the thud sound behind the dash?
 




rrgone

Active Member
Joined
July 9, 2006
Messages
770
Reaction score
5
City, State
Tucson, AZ
Year, Model & Trim Level
'02 XLT
Would any of those have caused the thud sound behind the dash?

Actually, no. I missed that in your first post. :(

Sounds like one of the HVAC doors has broken loose and falled over somewhere. Have you looked to see if the fresh air/ recirc door has fallen down on top of the blower? That's another pretty common issue with this generation explorer.
 




Exproblems

Well-Known Member
Joined
April 17, 2011
Messages
1,687
Reaction score
10
City, State
Orchard Park, N.Y.
Year, Model & Trim Level
'05 Explorer XLT 4.0L
Hi,

I have a 2004 Explorer Eddie Bauer V8 with dual climate temperature control. .>>>>>>>>>>> When I turned the car on I would hear a loud thud coming from behind the dash and then the heat would turn on. However, now I no longer hear the thud, the last time I hear the thud it sounded like plastic breaking and falling down, but I only get lukewarm air from all the vents (driver, passenger, back seats, and front defrost).

I am not sure what the problem is. I have looked into the Blend door
Thanks for the help.

I agree with "RRgone", could be the "fresh air recirculation door", since you mentioned the "sound of plastic breaking and falling down" and that you do get luke warm air from the dash vents. When you turn on the fan blower to high speed, does it come out of the vents at high speed or does it seem to be blocked by something and only trickle out of the vents? If the blower air comes out of the vents as a trickle, then the fresh air recirculation door fell off it's hinge points and is laying flat over the blower box and blocking the dash vent air flow coming from the fan blower. Just removing the air recirc door is easy(4 screws) to restore blower air flow back to the dash, but to re-install the door is a bigger job. The blower box is right behind the glove box and that is where you can remove the air recirc door. I'll be right back with a post link for that repair, have to go look it up. On that thud sound you heard, that may have been the fresh air door slamming shut or one of your temp blend doors.

Below is a link to a post by "Eyeinthesky". Look at the 12th, 13th and 14th photo in his post and that is where the air recirc door can be removed and where it sits in it's normal housing. The 12th photo with his hand in the pic, is where you split open the air box after removing the 4 screws, 2 on each side of front of box, and the air recirc door would be laying flat on it's side just inside of the open box in the pic. The door panel is approx 5 in H by 11in L. Might have to use needle nose pliers to grab on to it to pull it out thru the opeing if this is your problem.

http://www.explorerforum.com/forums/showthread.php?t=316624
 




mbundy1

New Member
Joined
January 16, 2013
Messages
4
Reaction score
0
Year, Model & Trim Level
2004 Explorer Eddie Bauer
When I switch from AC to heat the air flow does drop to about half of what it was so this is starting to all sound right.

Thank you guys, I have tomorrow off so I am going to take a look at it and I will let you know how it goes.
 




BGN

Active Member
Joined
February 9, 1999
Messages
182
Reaction score
1
I have been following this thread for a few days now and have a question...my 02 EB with ETAC has the creaking/clicking sound when first started...airflow from the vents has always seemed somehow restricted but I never thought much of it...heat is OK but it could be better although the AC can be almost too cold sometimes...last nite I noticed when RECIRCULATE is selected (the light comes on) that it goes out after a few minutes...can these all be related somehow to the door or is it something else?

Regards,
Barry
 




Top