• Register Today It's free! This box and some ads will disappear once registered!

Mass Air flow Sensor

DanB

Member
Joined
July 13, 1999
Messages
30
Reaction score
0
City, State
Klamath Falls, OR 97601
Year, Model & Trim Level
91 Sport
I know this has been talked about before, but I've been having a problem with a small miss even after cleaning the sensor. I've got the KK filter system, HyperTech chip, and a cat back free flow exhaust. I'll clean the sensor, and everything will be great for a couple thousand miles. Then my miss comes back. Clean the sensor again and it goes away again. Throttle position sensor, plug wires, platinum plugs are new. Any ideas?
 




S.Matsushige

Well-Known Member
Joined
February 11, 1999
Messages
332
Reaction score
0
City, State
Kapolei, Hawaii
Year, Model & Trim Level
1991 XLT
Dan-Have you changed your fuel filter? What year is your Explorer? You might check the fuel pressure regulator. The one on my '91XLT recently went bad with a damaged diaphram causing a rich fuel mixture and missing slightly in the beginning, eventually causing the engine to smoke and blow fuel pass the cylinders and into the oil. It felt like I was running on only four cylinders. Its not a hard fix. Ford wanted $680 for the diagnostics, oil and filter change, plug change and to replace the regulator. I just paid them for the diagnostics and did everything myself for a quarter of what they wanted. The plugs didn't need replacing as they said. I pulled them and cleaned them off and put them back in. I highly recommend these Bosch Platinum+4s. Anyway, I hope this helps.
 




DanB

Member
Joined
July 13, 1999
Messages
30
Reaction score
0
City, State
Klamath Falls, OR 97601
Year, Model & Trim Level
91 Sport
Thanks for your reply. My rig is a 91 Sport with 133,000 miles. I change the fuel filter every 18 months or so because of the dust, mud and snow that we run in up here in Oregon, so its only about 6 months old. I also had the diapragm intermittently stick open on the fuel pressure regulator last summer causing the fuel pressure to go to 90psi. This also caused the catalytic converter to clog big time, so those have been replaced. I've tried using 3 types of solvents to clean the mass air flow sensor, with the last one being acetone, so we'll see how that works.
 




Top