Message center flashing with turn signal | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

Message center flashing with turn signal

idoticsoigpa

Member
Joined
July 19, 2011
Messages
28
Reaction score
0
City, State
Springfield, MO
Year, Model & Trim Level
1998 Eddie Bauer V8 AWD
I have a 1998 Eddie Bauer AWD 5.0. For the past several months, every few weeks, the left turn signal would lock up, with the instrument panel left green arrow, front left turn signal lights and rear left turn signal all on solid, even with the turn signal lever in the middle off position. I would move the turn signal lever back and forth between the off and left turn signal position a few times and it would unlock it. Today, it locked up and stayed that way for a 100 mile drive. I got home, turned the engine off, turned the key back on and moved the turn signal lever a few times and the turn signal started working again, but now the message center and Automatic Temperature Control display flash in sync with the turn signal. The external lights are flashing and the green left arrow on the instrument panel are all flashing OK, except the message center and temp control display are flashing along with them. A right turn signal does not cause the flashing message center problem. Could this be the turn signal switch in the steering column or something else?
 


Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




swetrid

Explorer Addict
Joined
September 30, 2010
Messages
1,888
Reaction score
3
City, State
Reading Pa
Year, Model & Trim Level
1999 Eddie Bauer
Sounds like bad multifunction switch to me.
 




idoticsoigpa

Member
Joined
July 19, 2011
Messages
28
Reaction score
0
City, State
Springfield, MO
Year, Model & Trim Level
1998 Eddie Bauer V8 AWD
cause found

It was some kind of aftermarket trailer wiring device that was shorted out. Bought and installed a new multi function switch when I didn't need to.
 




Steeda04SVT

Well-Known Member
Joined
March 14, 2011
Messages
552
Reaction score
0
City, State
Kansas City, MO
Year, Model & Trim Level
1997 Eddie Bauer Explorer
Mine just started to flash today when when I turn on my right turn signal. The message center flashes with it.
 




Steeda04SVT

Well-Known Member
Joined
March 14, 2011
Messages
552
Reaction score
0
City, State
Kansas City, MO
Year, Model & Trim Level
1997 Eddie Bauer Explorer
It was some kind of aftermarket trailer wiring device that was shorted out. Bought and installed a new multi function switch when I didn't need to.

How did you trace it to that? I have trailer wiring harness as well but never have used it or anything. So just curious how you found it.
 




idoticsoigpa

Member
Joined
July 19, 2011
Messages
28
Reaction score
0
City, State
Springfield, MO
Year, Model & Trim Level
1998 Eddie Bauer V8 AWD
I took it to a Ford dealer complaining of the symtoms. They found the aftermarket wiring device on it somewhere, they described it as a box, and said it had a short in it. I just told them to get my lights working again, they took the device off. I probably don't have trailer wiring on the Explorer now, and I have a utility trailer I pull sometimes.
 




Steeda04SVT

Well-Known Member
Joined
March 14, 2011
Messages
552
Reaction score
0
City, State
Kansas City, MO
Year, Model & Trim Level
1997 Eddie Bauer Explorer
I got lucky, when I first turned on my vehicle this morning, my right turn signal was turned on and stuck on and when I turned to my left turn signal, every single light on my dash was flashing, well I went to go look and one of my LED amber turn signals up front wasn't coming on, so I popped off the headlight real quick and flipped the LED bulb around and voila, works like a champ again. Def dodged that bullet.
 




Top