• Register Today It's free! This box and some ads will disappear once registered!

^^Searches ExplorerForum.com^^

mileage display not very bright


rlgdguy

Member
Joined
April 12, 2010
Messages
57
Reaction score
0
City, State
Malden, MA
Year, Model & Trim Level
2005 Explorer XLT V6
The area around the 4 resistors on my cluster looked exactly like the ones in the picture by Denny. I knew that was my problem. I re-soldered the resistors and so-far-so-good, knock on wood. I got the 30 watt pencil soldering iron at walmart for $10. It came with the rosin core solder. Got the Ex in February and had been meaning to fix the display since then. It was driving me nuts. It's nice to have it working properly.
OK I'm no master solderer or welder but I was always told that simply replacing solder does not necessarily "fix" anything because solder is not a conductor of electricity. My serious question is do I bend the end of the resistors so they are touching the green side of the board or will the fit be snug enough that when the old solder is gone there will be contact already and the new solder is simply holding it in place? Thanks for any advice in advance.
 

Join the Elite Explorers for $20. Gets rid of the ads!

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.



rlgdguy

Member
Joined
April 12, 2010
Messages
57
Reaction score
0
City, State
Malden, MA
Year, Model & Trim Level
2005 Explorer XLT V6
What do you mean its not out of a '02?

Its in this ya goofball.
eddie1.jpg
Looks exactly like mine bug shield and all. Nice looking vehicle! ;)
 


2Trux

Active Member
Joined
March 14, 2011
Messages
307
Reaction score
21
City, State
Albuquerque, NM
Year, Model & Trim Level
2005 Limited V8 4X4
OK I'm no master solderer or welder but I was always told that simply replacing solder does not necessarily "fix" anything because solder is not a conductor of electricity. My serious question is do I bend the end of the resistors so they are touching the green side of the board or will the fit be snug enough that when the old solder is gone there will be contact already and the new solder is simply holding it in place? Thanks for any advice in advance.
Solder is a metal and a conductor. Resoldering bad connections is a great way to fix electrical problems.
If all the solder did was hold the part in place they could just glue it on. BTW the green stuff on the board is an insulating coating to keep the copper traces from corroding.
 
Last edited:


BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,886
Reaction score
11
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4
Solder is a metal and a conductor. Resoldering bad connections is a great way to fix electrical problems.
If all the solder did was hold the part in place they could just glue it on. BTW the green stuff on the board is an insulating coating to keep the copper traces from corroding.
I concur! :)
 


rlgdguy

Member
Joined
April 12, 2010
Messages
57
Reaction score
0
City, State
Malden, MA
Year, Model & Trim Level
2005 Explorer XLT V6
Solder is a metal and a conductor. Resoldering bad connections is a great way to fix electrical problems.
If all the solder did was hold the part in place they could just glue it on. BTW the green stuff on the board is an insulating coating to keep the copper traces from corroding.
It didn't make sense to me either, but I never had the need to solder anything, so never researched it before.

That's why I love this forum. The information is spot on and people know their sh!t. Thanks for the info. Looking forward to tackling this task and will update with results!
 


rlgdguy

Member
Joined
April 12, 2010
Messages
57
Reaction score
0
City, State
Malden, MA
Year, Model & Trim Level
2005 Explorer XLT V6
We change the resistors. Work like new. I'l give some feedback in a few month.
I know they'll say on them, but what resisitors are these exactly, so I know to get the right ones if I decide or need to replace? Thanks in advance for any info!
 


TCPRR

New Member
Joined
April 4, 2012
Messages
9
Reaction score
0
City, State
Grand Rapids Michigan
Year, Model & Trim Level
2001 Explorer Sport Trac
Great Post, followed the instruction and solved my son's 2002 Explorer Odometer display gone.
 


Styx

Active Member
Joined
July 2, 2004
Messages
306
Reaction score
5
City, State
Chilliwack BC Canada
Year, Model & Trim Level
02 eddy 93&13 limited
Just picked up an 02 on the weekend for a very good price has a couple problems and this is one of them... Love this place... I will be fixing this and the air bag light too...
Thanks all...
 


BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,886
Reaction score
11
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4


Styx

Active Member
Joined
July 2, 2004
Messages
306
Reaction score
5
City, State
Chilliwack BC Canada
Year, Model & Trim Level
02 eddy 93&13 limited
So I pulled mine apart and it was just like 34ford's cluster. mine is a canadian truck so I wonder if this is a differance. the resistors are there but not loose.. I did find a burn mark on the face of the info center cluster. I'm guessing it is going to need a cluster...damn... At least I got the 6 stack cd player working...
Cheers Randy...


Oh and I did take pictures and I will post them soon...
 


chewie1014

New Member
Joined
September 24, 2012
Messages
1
Reaction score
0
City, State
Durham, NC
Year, Model & Trim Level
2002 Explorer XLS 4x4
Awesome post. Just fixed the odometer in my '02 Explorer using Denny347's instructions. Awesome!!!

My cluster looked like Denny347's. Found 2 bad connections in the resistor welds. Resoldered all of them just to make sure. Took about an hour start to finish and that included getting the tools out of the shed. FYI, you'll need a 7mm socket and a T15 torx...that's it. Oh, and a pencil soldering iron and flux.
 


Extremistno9

New Member
Joined
July 4, 2009
Messages
48
Reaction score
0
City, State
Milwaukee, WI
Year, Model & Trim Level
Ford Explorer 02XLT 07EB
I have the same problem. Display went out the second I drove it off the dealers lot! Gotta love how that happens. Anyways, I am hoping to do this project this weekend with positive results. Thanks in advance for the information!
 


BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,886
Reaction score
11
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4


Extremistno9

New Member
Joined
July 4, 2009
Messages
48
Reaction score
0
City, State
Milwaukee, WI
Year, Model & Trim Level
Ford Explorer 02XLT 07EB
Worked on it this morning with the help of my 4 year old son. Easy to do and works great! Denny347 and XtremeRanger, thank you so much for the great write up on this fix! Probally took about 60-90 mins including all the breaks and distractions. 4 of the soldier joints were non-existant but should hold for a while now.
 


BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,886
Reaction score
11
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4
Worked on it this morning with the help of my 4 year old son. Easy to do and works great! Denny347 and XtremeRanger, thank you so much for the great write up on this fix! Probally took about 60-90 mins including all the breaks and distractions. 4 of the soldier joints were non-existant but should hold for a while now.
Nicely done. Thanks for the update. :biggthump
 


trucku

Well-Known Member
Joined
January 25, 2005
Messages
2,028
Reaction score
2
City, State
Queens, New York and living in Budd Lake, NJ now.
Year, Model & Trim Level
2002 Explorer XLS 4.0 4x4
Just fixed my display. No more whacking at console to get the mileage to show up. Found one loose joint that I could see right away. Longest part of the fix was waiting for the solder iron to heat up. Great pictures!
 


BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,886
Reaction score
11
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4
Just fixed my display. No more whacking at console to get the mileage to show up. Found one loose joint that I could see right away. Longest part of the fix was waiting for the solder iron to heat up. Great pictures!
I couldn't have said it any better! This part made me laugh:

:bsnicker:

Longest part of the fix was waiting for the solder iron to heat up.
 


trucku

Well-Known Member
Joined
January 25, 2005
Messages
2,028
Reaction score
2
City, State
Queens, New York and living in Budd Lake, NJ now.
Year, Model & Trim Level
2002 Explorer XLS 4.0 4x4
I couldn't have said it any better! This part made me laugh:

:bsnicker:

LOL Thanks!:thumbsup:

So weird having it working now. I keep looking down at it while I drive...:D
 


BigRondo

USMC 1371
Elite Explorer
Moderator Emeritus
Joined
February 15, 2010
Messages
7,886
Reaction score
11
City, State
Worcester, MA
Year, Model & Trim Level
2002 XLT V6 4x4
LOL Thanks!:thumbsup:

So weird having it working now. I keep looking down at it while I drive...:D
I still do that, half expecting it to be out again but so far so good!!
 

Join the Elite Explorers for $20. Gets rid of the ads!

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see practically no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.



orthoguy

New Member
Joined
May 19, 2007
Messages
31
Reaction score
0
City, State
Grand Rapids, Michigan
Year, Model & Trim Level
2015 Explorer XLT
Well, I too just wasted my time pulling this cluster out, I have the exact same one you do! 2002 Explorer! From what I see in the pics now, the one that was used here as an example doesn't have the message center and mine does, I guess that is the difference.







What do you mean its not out of a '02?

Its in this ya goofball.
eddie1.jpg
 


Thread starter Similar threads Forum Replies Date
G Brought it back from the dead! High Mileage, but want to make it healthy Stock 2002 - 2005 Explorers 1
9 High Mileage Oil Stock 2002 - 2005 Explorers 8
L 2002 ford explorer mileage gas bad Stock 2002 - 2005 Explorers 9
H mileage question Stock 2002 - 2005 Explorers 0
S Checking mileage... Stock 2002 - 2005 Explorers 3
F need help figuring out why low gas mileage Stock 2002 - 2005 Explorers 1
K 2005 XLT 4.0 V6 Horrible Gas Mileage Stock 2002 - 2005 Explorers 11
A Major Mileage Milestone! Stock 2002 - 2005 Explorers 44
M NGK G-Power plugs causing poor mileage on a 4.6? Stock 2002 - 2005 Explorers 11
G gas mileage Stock 2002 - 2005 Explorers 7
M High Mileage Oil Suggestions Stock 2002 - 2005 Explorers 15
F Bunch of Codes, Rough idle and poor mileage. Stock 2002 - 2005 Explorers 5
M 2004 4.6 tuned up, now mileage has tanked Stock 2002 - 2005 Explorers 3
J Fuel Mileage, Open to everyone Stock 2002 - 2005 Explorers 15
W How to reset the mileage odometer when swapping clusters? Stock 2002 - 2005 Explorers 14
M Poor fuel mileage, exhaust stinks, my converter(s) are probably toast, right? Stock 2002 - 2005 Explorers 5
S Highest Mileage 4.0, V-6, Explorer Stock 2002 - 2005 Explorers 23
J Gas Mileage Stock 2002 - 2005 Explorers 12
C Bad gas mileage and no heat at an idle, HELP!!!! Stock 2002 - 2005 Explorers 2
O Gas Mileage Drop after fuel filter??? Stock 2002 - 2005 Explorers 44
N Crazy Mileage drop, o2 sensor? Stock 2002 - 2005 Explorers 12
S Gas mileage Stock 2002 - 2005 Explorers 1
R Worse mileage with cruise control?? Stock 2002 - 2005 Explorers 4
0 Is this bad gas mileage Stock 2002 - 2005 Explorers 12
C Ok to replace tensioners on a high mileage engine? Stock 2002 - 2005 Explorers 1
Q Help with Poor Mileage Stock 2002 - 2005 Explorers 1
G My 05 Explorer XLT Gas Mileage Stock 2002 - 2005 Explorers 3
rewind1 Hesitation/Power Loss and Poor Gas Mileage - 03 V8 Stock 2002 - 2005 Explorers 5
C High Mileage 4.6 motors. How many miles do you currently have? Stock 2002 - 2005 Explorers 4
G What kind of mileage is your 3rd gen getting? Stock 2002 - 2005 Explorers 76
S high mileage tuneup Stock 2002 - 2005 Explorers 3
L Increasing gas mileage... Stock 2002 - 2005 Explorers 29
Y High Mileage Road Trip Stock 2002 - 2005 Explorers 6
S Im stumped, terrible gas mileage Stock 2002 - 2005 Explorers 17
S How to get Better Gas Mileage? Stock 2002 - 2005 Explorers 34
T Low mileage 05 or higher mileage 07? Stock 2002 - 2005 Explorers 12
X Normal Gas Mileage? Stock 2002 - 2005 Explorers 29
K Gas mileage in '02 4.0 V6 Stock 2002 - 2005 Explorers 5
zecolleman Best mileage Highway/city Stock 2002 - 2005 Explorers 19
T Why does my 02 get better mileage than my 06? Stock 2002 - 2005 Explorers 5
G gas mileage Stock 2002 - 2005 Explorers 17
S High-mileage Explorers - going to be a problem? Stock 2002 - 2005 Explorers 18
S At what mileage did you replace your shocks? Stock 2002 - 2005 Explorers 12
F Suggestions on High Mileage Motor Oil to use Stock 2002 - 2005 Explorers 4
S 2005 V8 Mountaineer Mileage Problem Stock 2002 - 2005 Explorers 6
shadowless127 High Mileage 02 Mountaineer awd v8 Stock 2002 - 2005 Explorers 2
D Bad Fuel mileage 04 Stock 2002 - 2005 Explorers 4
C Mileage dropped to 16 and idle shakes the truck Stock 2002 - 2005 Explorers 10
shadowless127 Still getting crap gas mileage Stock 2002 - 2005 Explorers 14
S Bad gas mileage? Stock 2002 - 2005 Explorers 29
Similar threads


















































Top