• Register Today It's free! This box and some ads will disappear once registered!

More help needed with seats in 2014 PIU

16vcabman

Member
Joined
February 25, 2020
Messages
46
Reaction score
7
City, State
Ortonville
Year, Model & Trim Level
2014 piu
Hello and need some help with police seats to leather Explorer seats from a 2013 explorer. They plugged in and power works on left and see right needs power no problem. Here is issue, airbag light came on. I don't have a scanner so can't get data. Was wondering if Explorer seats have wires swapped in connector? Or is seat air bag culprit. Thanks for any guidance. Car had battery disconnected for 15 minutes before unplugging and then had car running and the light came on in dash.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
30,002
Reaction score
2,064
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Do the 2nd row seats have the airbag seatbelts or did they originally? That could likely be the problem.

Peter
 




DHG2496

Well-Known Member
Joined
October 4, 2019
Messages
121
Reaction score
18
City, State
Fruitport, MI
Year, Model & Trim Level
14 Explorer PIU 3.5EB
Hello and need some help with police seats to leather Explorer seats from a 2013 explorer. They plugged in and power works on left and see right needs power no problem. Here is issue, airbag light came on. I don't have a scanner so can't get data. Was wondering if Explorer seats have wires swapped in connector? Or is seat air bag culprit. Thanks for any guidance. Car had battery disconnected for 15 minutes before unplugging and then had car running and the light came on in dash.
Not that I'd want to do this but could disassemble your Police seats and swap the air bag seat sensor and wiring, if you know it was good in the old seats and suspect the new one might be bad, you could do this but I'm sure that is a huge PIA! but at least you know you have working sensors in those.

I was given my seats from the guy I purchased from, so don't now what they came out of but I thought 11-14/15 were all supposed to be compatible with no change in sensors. Maybe just doublecheck the wiring and plugs under the seat and in the larger on in the floor.
 




16vcabman

Member
Joined
February 25, 2020
Messages
46
Reaction score
7
City, State
Ortonville
Year, Model & Trim Level
2014 piu
Not that I'd want to do this but could disassemble your Police seats and swap the air bag seat sensor and wiring, if you know it was good in the old seats and suspect the new one might be bad, you could do this but I'm sure that is a huge PIA! but at least you know you have working sensors in those.

I was given my seats from the guy I purchased from, so don't now what they came out of but I thought 11-14/15 were all supposed to be compatible with no change in sensors. Maybe just doublecheck the wiring and plugs under the seat and in the larger on in the floor.
Thanks for your reply. Actually found out that if the car had an airbag deployment any airbags have to be reset. I took them back and got others from a different yard and all is well now.
 




16vcabman

Member
Joined
February 25, 2020
Messages
46
Reaction score
7
City, State
Ortonville
Year, Model & Trim Level
2014 piu
Do the 2nd row seats have the airbag seatbelts or did they originally? That could likely be the problem.

Peter
Hi Peter, it was the from the front seats. I did some research and if an airbag deployed, any that didn't have to be reset before use again. I got other seats and problem went away.
 




Top