My 85 B2 w/4.0 swap and more... | Page 3 | Ford Explorer - Ford Ranger Forums - Serious Explorations

  • Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership! If you have an existing Elite membership contact me by PM and I will upgrade your account manually.

    Click Here to start your membership and get rid of the ads!

My 85 B2 w/4.0 swap and more...



Holiday Special! Join the Elite Explorers $20 for 2 years! Gets rid of the ads!

Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private conversations, and more. Join Today. Your support is greatly appreciated.




4x4junkie

Explorer Addict
Joined
March 28, 2002
Messages
1,344
Reaction score
7
City, State
So.Calif.(San Fernando Valley)
Year, Model & Trim Level
'94 Ranger, '90 Bronco II
No the column is a 91 Explorer. That's what is messing me up. I thought if I use that column it would work but guess not..

I see no reason for it not to work...

Whatever is causing it is probably somewhere between the multifunction switch and the brake lamp wires going out to each bulb.

When the turn-signal stalk is in the middle, you should have continuity between both of your brake lamp wires, but the continuity should break when you flip it up or down for a turn. To me it sounds like that continuity might not be getting disconnected when you flip the stalk and is why both lights are trying to flash.
Does hitting the brake affect your blinkers at all too?
 




ceirsik

Member
Joined
March 9, 2013
Messages
25
Reaction score
0
City, State
hutchinson, ks.
Year, Model & Trim Level
85 bronco II
When I hit the brakes they over ride the blinkers and they stop. Thanks for thumbs up. I'm not going to make it to high.. Just to the top of the grill.
 




4x4junkie

Explorer Addict
Joined
March 28, 2002
Messages
1,344
Reaction score
7
City, State
So.Calif.(San Fernando Valley)
Year, Model & Trim Level
'94 Ranger, '90 Bronco II
Yea so it's definitely something to do with the two brake lamp circuits not separating properly when you turn your blinkers on. That's where I'd begin troubleshooting with a meter, test light, etc. (pull the brake lamp bulbs out so you won't have the bulb filaments connecting the circuits to ground while you try to test them).

×2 on the winch, looks good (kindof how mine is, tucked under the grill a bit)


Good luck on it.
 




ceirsik

Member
Joined
March 9, 2013
Messages
25
Reaction score
0
City, State
hutchinson, ks.
Year, Model & Trim Level
85 bronco II
OK.. I added a small bar in front of the winch next a stinger...
IMAG0410_zps5b3df971.jpg

IMAG0409_zps47165244.jpg

IMAG0420_zps0e12114c.jpg

IMAG0422_zpsd3f57ff1.jpg


On the stinger after I bent it I didn't like the way it creased at the bends, so I fixed it...
IMAG0412_zps48c3cd2e.jpg

IMAG0415_zpsc3d1d5ae.jpg

IMAG0413_zpsd83cce53.jpg

IMAG0418_zps6a375c4e.jpg

IMAG0419_zps4f1b45c5.jpg


Still not done but looking better, I think!
 




ceirsik

Member
Joined
March 9, 2013
Messages
25
Reaction score
0
City, State
hutchinson, ks.
Year, Model & Trim Level
85 bronco II
I got the bumper done, I'll have to get some pics loaded. I found a 93 Explorer with this rear end tag.
IMAG0490_zps9705448c.jpg


I'm getting the hole explorer to get what I need. has 79K on it. Now with the D35 front, I will need to buy manual locking hubs? Or is there another set that will work on it?

Also found some these at the u-pull.
IMAG0435_zps9345008e.jpg


Will these springs work on my B2?
IMAG0434_zps069c0418.jpg


It's complete.
IMAG0438_zpsa2796e8a.jpg


IMAG0450_zpsb3d15207.jpg


Just thought I would share..
 




ceirsik

Member
Joined
March 9, 2013
Messages
25
Reaction score
0
City, State
hutchinson, ks.
Year, Model & Trim Level
85 bronco II
Ok, got the 93 explorer and with the auto front hubs, can I use the manual locking ones from the f150 on the D35 front? Or do I have to buy new ones?

Thanks, Chris. Oh, I have new pics to upload later today.
 




rookieshooter

Moderator Emeritus
Joined
March 13, 2005
Messages
7,290
Reaction score
1
City, State
Martinsburg WV
Year, Model & Trim Level
84 BII "Li'l Samson"




Backwoods "X"

Well-Known Member
Joined
June 20, 2011
Messages
220
Reaction score
1
City, State
Mt. Sterling, Ky
Year, Model & Trim Level
94 XLT
This guy(? My daughter and wife are building up the 94 "X" that belongs to my wife, hence the ?) is getting with it on the buildup! Welcome and Rock on on the build up.
 




Top