My Speakers Hiss can anyone help? | Ford Explorer - Ford Ranger Forums - Serious Explorations
  • Register Today It's free!

My Speakers Hiss can anyone help?

hotshot5231

New Member
Joined
June 22, 2003
Messages
1
Reaction score
0
City, State
Maryville, Tennessee
Year, Model & Trim Level
99 Sport
Hi, I have a 99 sport. I have the factory head unit which i soon plan to replace, a FM modulated sony xplod 10 cd changer, and 4 pioneer 6x8 4 way speakers. When playing cd's my speakers tend to hiss a crack as if there is bad reception on a radio station. Can anyone tell me why this might be?
 






twomedicine

Well-Known Member
Joined
June 13, 2003
Messages
303
Reaction score
0
City, State
Wilm., DE
Year, Model & Trim Level
99 XL
crackling sound system

The only things I can think of are simple:

Your connections at the speaker terms are poor. I used solder on my Pioneers so any vibrations wouldn't add up and cause a faulty connection. Maybe the wire going into the solderless connector, if used, is failing at that point.

If you get crackling while turning a knob, using the switches, like fade, or balance, there could be dust/dirt causing the static.

Only other thing comes to mind is a ground wire that's loose or almost broken, or maybe a speaker has gone bad. Maybe your speakers are not in phase, but that usually shows up as weak sound(due to installation error; the wires to the speakers are not connected to the correct teminals)

You've probably already thought of these things, but it's the best I can come up with~

twomedicine
 






onelasttry

Well-Known Member
Joined
April 22, 2003
Messages
361
Reaction score
0
City, State
Chattanooga, TN
Year, Model & Trim Level
1997 xlt 2wd 5 speed 2.3L
you either have a defective modulator, or it isnt set to the correct frequency.
 






Top