• Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!

    Click Here to start your membership and get rid of the ads!

"NAV SD Card Fault"


drosenth

New Member
Joined
February 15, 2016
Messages
10
Reaction score
0
City, State
Indianapolis
Year, Model & Trim Level
2014 Explorer Sport
Greetings,

I have been having this exact same issue for a month now. Tried two map SD cards, neither work. My hub is down/not working either. I have the APIM recall as well as an extended warranty on my 2014, so it's off to the dealer soon to fix. The Nav would at times work after this failure, but it wasn't working right and only works for one trip. I will keep folks posted.

Thanks,
Dave

Hello,

Update - under my extended warranty dealer confirmed USB hub was bad. Replaced and working fine. For me my A4, A6 but more importantly USB cables / charging did t work which really drove me to believe it was the USB hub / block. Working great here. Had to drop $100 deduct but all good.

This is closed out for me - good luck and test your USB if you have the same issue - this helped me troubleshoot BUT dealer could test and repeat the fault.

Thanks,
Dave
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,598
Reaction score
1,770
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Hello,

Update - under my extended warranty dealer confirmed USB hub was bad. Replaced and working fine. For me my A4, A6 but more importantly USB cables / charging did t work which really drove me to believe it was the USB hub / block. Working great here. Had to drop $100 deduct but all good.

This is closed out for me - good luck and test your USB if you have the same issue - this helped me troubleshoot BUT dealer could test and repeat the fault.

Thanks,
Dave
Appreciate the update Dave.

Peter
 




FordIVTteam

Official Ford Rep
Joined
July 13, 2011
Messages
1,690
Reaction score
1
City, State
Dearborn, MI
Year, Model & Trim Level
Ford Explorer
We are calling it FIXED. We drove it for over 100 miles now, no issues. So replacing the card with an A7 (I got it on Amazon) worked for me. Now everything is back to normal.

That's great to hear! I'm glad everything is going well now. I'll be here if anything else comes up.

Hello,

Update - under my extended warranty dealer confirmed USB hub was bad. Replaced and working fine. For me my A4, A6 but more importantly USB cables / charging did t work which really drove me to believe it was the USB hub / block. Working great here. Had to drop $100 deduct but all good.

This is closed out for me - good luck and test your USB if you have the same issue - this helped me troubleshoot BUT dealer could test and repeat the fault.

Thanks,
Dave

This is great news! Thanks for the update. Feel free to reach out in the future if you need assistance.

Shaay
 




FordIVTteam

Official Ford Rep
Joined
July 13, 2011
Messages
1,690
Reaction score
1
City, State
Dearborn, MI
Year, Model & Trim Level
Ford Explorer
We are calling it FIXED. We drove it for over 100 miles now, no issues. So replacing the card with an A7 (I got it on Amazon) worked for me. Now everything is back to normal.

That's great to hear! I'm glad everything is going well now. I'll be here if anything else comes up.

Hello,

Update - under my extended warranty dealer confirmed USB hub was bad. Replaced and working fine. For me my A4, A6 but more importantly USB cables / charging did t work which really drove me to believe it was the USB hub / block. Working great here. Had to drop $100 deduct but all good.

This is closed out for me - good luck and test your USB if you have the same issue - this helped me troubleshoot BUT dealer could test and repeat the fault.

Thanks,
Dave

This is awesome news! Thanks for the update. Feel free to reach out in the future if you need assistance.

Shaay
 




JetBomber

New Member
Joined
August 23, 2016
Messages
7
Reaction score
0
City, State
New Jersey
Year, Model & Trim Level
2016 Explorer Limited v6
I hate to report that my 2016 Limited AWD is now getting the NAV SD Card Fault. Based on what I've read so far, I'm not sure whether to bring in to dealer or to contact HERE for a replacement card. I have an A6 card and I tried taking it out/putting it back in and tried restarting the car. I have an extended warranty and will not be a happy camper if this has to come out of my pocket.
 




sjs91

New Member
Joined
April 26, 2017
Messages
1
Reaction score
0
Year, Model & Trim Level
2013 Explorer Limited
Hello,

Not sure this is on the right thread because I haven't gotten the "Nav SD Card Fault" message but I am having an issue with the navigation on my 2013 Explorer Limited. For the last couple of months I've noticed the Nav isn't picking up where I actually am. I'll be pulling into work and it shows I'm still at home or I'll be picking the kids up from school and it shows I'm still at work. I read through this thread and someone suggested a possible issue with having an iPhone connected via Bluetooth. So I drove around tonight with the Bluetooth on and off on both my phone and my wife's. Nav didn't work when the phones were connected but immediately started working when the phones were disconnected. I tried the same thing in our 2015 Taurus but Nav worked with either phone connected so I'm thinking it's not the phones. The SD card in the Explorer is an A4 and the Taurus I'd an A5.

Sorry for the long explanation but any thoughts on what is going on?
Thanks
 




Chris Bednar

New Member
Joined
June 26, 2017
Messages
3
Reaction score
0
City, State
Zionsville, Indiana
Year, Model & Trim Level
2016 4DR LTD Explorer 4WD
I have a 2016 4 DR LTD Explorer 4WD that I paid almost $50K for that has this problem among others. Since we purchased the vehicle, the Navigation SD Card Fault issue has plagued us. We have taken the car to the dealership at least 5 times for this issue, and they try things that don't resolve the issue permanently. Just a month ago we left the vehicle with the dealer for over a week to repair, and it hasn't improved. On top of this issue, we have had other odd computer related issues, such as:
  • The driver-side seat automatically moves as far forward as it can when you start the car after using the keypad to unlock the doors.
  • The USB drive that is next to the Navigation SD card slot only works sporadically.
  • The driver-side mirror automatically tries to adjust to the left and will continue to try and move to the left until it just clicks repeatedly. This occurs upon starting the car after using the keypad again.
  • Backseat heat warmer flaked out after 18 months.
The dealer, Pearson Ford in Zionsville Indiana, has not been very helpful in trying to resolve these issues. Repeatedly, we leave without resolution. After leaving the car with them for several days at a time, and over a week recently, they haven't resolved the issue with the Navigation SD Card Fault. The Repair Shop Manager screens the calls from us, and won't answer and/or return our calls. We're required to use other attempts to schedule appointments now. We are at the end of our wits to get this issue resolved.

Any ideas or suggestions?
 




wilexplorer

Member
Joined
December 18, 2015
Messages
61
Reaction score
0
Year, Model & Trim Level
2016 Explorer XLT
I would say email Ford customer service, You need to talk to customer service at regional level. Be nice and ask for a resolution
 




thefranchise713

Well-Known Member
Joined
April 22, 2016
Messages
1,246
Reaction score
156
City, State
Buffalo, NY
Year, Model & Trim Level
'18 Toyota Prius Prime
All of these issues are connected to different modules.

Purely a guess, but either you have a battery that's pushing out weird voltage (considering how bad these batteries are, wouldn't surprise me) or there is an issue with one of the networks (not common).

If they can't figure it out themselves, they need to get a field service engineer out that way.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,598
Reaction score
1,770
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
I have a 2016 4 DR LTD Explorer 4WD that I paid almost $50K for that has this problem among others. Since we purchased the vehicle, the Navigation SD Card Fault issue has plagued us. We have taken the car to the dealership at least 5 times for this issue, and they try things that don't resolve the issue permanently. Just a month ago we left the vehicle with the dealer for over a week to repair, and it hasn't improved. On top of this issue, we have had other odd computer related issues, such as:
  • The driver-side seat automatically moves as far forward as it can when you start the car after using the keypad to unlock the doors.
  • The USB drive that is next to the Navigation SD card slot only works sporadically.
  • The driver-side mirror automatically tries to adjust to the left and will continue to try and move to the left until it just clicks repeatedly. This occurs upon starting the car after using the keypad again.
  • Backseat heat warmer flaked out after 18 months.
The dealer, Pearson Ford in Zionsville Indiana, has not been very helpful in trying to resolve these issues. Repeatedly, we leave without resolution. After leaving the car with them for several days at a time, and over a week recently, they haven't resolved the issue with the Navigation SD Card Fault. The Repair Shop Manager screens the calls from us, and won't answer and/or return our calls. We're required to use other attempts to schedule appointments now. We are at the end of our wits to get this issue resolved.

Any ideas or suggestions?
Welcome to the Forum.:wave:
Try another dealer if it has come down to screening calls. I'm guessing that there are no seat or mirror issues when not using the keypad. Is that right?

Peter
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,598
Reaction score
1,770
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
I would say email Ford customer service, You need to talk to customer service at regional level. Be nice and ask for a resolution
If you are referring to the Ford reps that were here before, they aren't anymore. Disappeared Jan. 31st.

Peter
 




Chris Bednar

New Member
Joined
June 26, 2017
Messages
3
Reaction score
0
City, State
Zionsville, Indiana
Year, Model & Trim Level
2016 4DR LTD Explorer 4WD
Welcome to the Forum.:wave:
Try another dealer if it has come down to screening calls. I'm guessing that there are no seat or mirror issues when not using the keypad. Is that right?

Peter

You are correct! No issues when not using the keypad.
 




Chris Bednar

New Member
Joined
June 26, 2017
Messages
3
Reaction score
0
City, State
Zionsville, Indiana
Year, Model & Trim Level
2016 4DR LTD Explorer 4WD
All of these issues are connected to different modules.

Purely a guess, but either you have a battery that's pushing out weird voltage (considering how bad these batteries are, wouldn't surprise me) or there is an issue with one of the networks (not common).

If they can't figure it out themselves, they need to get a field service engineer out that way.

Just had to replace that battery in it before we even hit 42k miles - it leaked and corroded the wire harness. Still having issues after the new battery and wire harness was replaced.
 




frequent flyer

New Member
Joined
February 3, 2016
Messages
6
Reaction score
0
Location
Rhode Island
Year, Model & Trim Level
2016 Explorer XLT
I am not new to this site, but new to this conversation, because two weeks ago my 2016 XLT suddenly began with the Nav SD card fault message at almost exactly 20,000 miles. (The card is an A6.) Looking back at previous posts, I realize this is a long, ongoing problem. Has ANY member come across a permanent, satisfactory fix? I am holding my breath on my wife's 2015 Lariat, because she uses the nav on that a lot.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,598
Reaction score
1,770
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
I am not new to this site, but new to this conversation, because two weeks ago my 2016 XLT suddenly began with the Nav SD card fault message at almost exactly 20,000 miles. (The card is an A6.) Looking back at previous posts, I realize this is a long, ongoing problem. Has ANY member come across a permanent, satisfactory fix? I am holding my breath on my wife's 2015 Lariat, because she uses the nav on that a lot.
Just wanted to say "Welcome to the Forum".:wave:

Peter
 




J

Jack Daniel

I am currently waiting on an A7 card from evil-bay. It is a Genuine Ford product as described. Is it just a straight swap?
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,598
Reaction score
1,770
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
I am currently waiting on an A7 card from evil-bay. It is a Genuine Ford product as described. Is it just a straight swap?
Curious as to why you didn't get an A8? Yes, you pop one card out and insert the other one. Since I've never swapped cards I don't know if it goes through any kind of 'reboot' or not.

Peter
 




J

Jack Daniel

I believe the A8 is only at the dealer so far, therefore a high price. The A7 was only $62.00.
My current one is A5 and has a hard time with some of the roads in Northern Ontario.
 




davlee88

Member
Joined
March 22, 2012
Messages
90
Reaction score
2
Year, Model & Trim Level
2013 Explorer Limited 2wd
Last week I purchased an a8 card from fleabay for $66
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




ESUguy

New Member
Joined
June 15, 2016
Messages
3
Reaction score
0
City, State
Olathe, KS
Year, Model & Trim Level
2015 Limited
Well, it's my turn with this problem. I'm at 36,500 miles on our '15, and have been getting the SD Card Fault error for the past week. Is Ford going to cover this since it's a known problem and I'm barely out of the warrantly mileage? Is the problem just that the cards go bad, or is the nav system crapping out?
 




Top