need help with aftermarket head unit | Ford Explorer Forums - Serious Explorations

  • Register Today It's free!

need help with aftermarket head unit

1meanGTA

Active Member
Joined
October 26, 2006
Messages
83
Reaction score
0
Year, Model & Trim Level
'98 Eddie Bauer
i just installed my clarion dxz955mc in my 98 eddie bauer, but when i turn the key to acc, nothing happens. when i start the truck, for a second the top and bottom of the HU light up like its about to come on, then it turns off.

it had a totally stock stereo before. the only wires in the harness im using are the power, acc, ground, and illumination. the damned power antenna wire fell out of my harness, thats right, wasnt pulled out, it fell out. i'm not sure which slot of the harness it goes into, does anyone have a diagram? it's not really a big deal since i never listen to the radio.

what would make it power on for a second only when the starter turns?
 



Join the Elite Explorers for $20 each year.
Elite Explorer members see no advertisements, no banner ads, no double underlined links,.
Add an avatar, upload photo attachments, and more!
.





nevermind, i tracked it to the wiring harness i got off ebay being a piece of ****. got a new one, and its good to go.
 






nevermind, i tracked it to the wiring harness i got off ebay being a piece of ****. got a new one, and its good to go.

lol, glad it worked out in the end though.
 






Good to hear you got your harness issues worked out.

I have the same HU in my 98. Here's a pic of my HU/DSP setup. How do you like yours so far?
 

Attachments

  • ClarionHU_PioneerEQDSP2_small.jpg
    ClarionHU_PioneerEQDSP2_small.jpg
    99.2 KB · Views: 366






i've had it for a while, had the same system in my trans am, only i was using 2 soundsplinter rl-p 12's in a 4.3 cubic foot box tuned to 30 hz. i love the options of the deck, except for the whole 2-way 3-way normal thing. doesnt leave enough eq adjustment options IMO. probably going to have a dsp also once i get everything settled and have some more cash to throw around. i just bought my explorer about 2 months ago, and dropped 250 on the alarm (without installation) 400 on the alternator, 600 on the 15's, so im hurting for cash right now. awesome looking deck though.
 






hey thats my HU, i had to look at your name again to see, hows it doing for you?

i loved that HU, but i like my indash even better
 






Back
Top