• Register Today It's free! This box and some ads will disappear once registered!

New v3.0 Build Available


yohanofUM

New Member
Joined
January 11, 2020
Messages
16
Reaction score
0
City, State
Ann Arbor, MI
Year, Model & Trim Level
2017 Explorer Sport
Welcome to the Forum.:wave:

Peter
Thank you :chug:
I play on jeepforum as well and after about 3 hours of fiddling with this mess, I thought it might be time to ask some pros.

EDIT: of course, after authoring the previous post(s), the "last try tonight dear, I promise" actually produced a clean checksum and I'm currently sitting in the vehicle watching the "Updating System Software..." message - afraid to move.
 
Last edited:


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




UofMEngineer

Active Member
Joined
July 18, 2019
Messages
247
Reaction score
50
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
Thank you :chug:
I play on jeepforum as well and after about 3 hours of fiddling with this mess, I thought it might be time to ask some pros.

EDIT: of course, after authoring the previous post(s), the "last try tonight dear, I promise" actually produced a clean checksum and I'm currently sitting in the vehicle watching the "Updating System Software..." message - afraid to move.
Did it work?
 




yohanofUM

New Member
Joined
January 11, 2020
Messages
16
Reaction score
0
City, State
Ann Arbor, MI
Year, Model & Trim Level
2017 Explorer Sport
Did it work?
Yes, but I cannot explain why. Perhaps it could sense my wife's glare and decided to spare me another lashing?

The map update is running now and no, I don't know why I paid $109 for something one would think should just be a routine update...but I did, because 15 to 18 seemed like a reasonable gap.

I'm still inside the factory warranty so I'm hesitant to start hacking the APIM for the 3.4 upgrade...
 




Sgt1411

Elite Explorer
Joined
February 22, 2011
Messages
4,323
Reaction score
351
City, State
VanBC/GoodyearAZ
Year, Model & Trim Level
2017 Explorer SPORT
Is SYNC3 v3.4 still out on web as unofficial beta version or is there an official OEM Ford release now?
 




UofMEngineer

Active Member
Joined
July 18, 2019
Messages
247
Reaction score
50
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
Is SYNC3 v3.4 still out on web as unofficial beta version or is there an official OEM Ford release now?
Some enterprising individual leaked an old reformatter so you can force an old module to run the new software. It's not meant to run with the older APIM firmware though, so there can be some oddities. Some configuration items won't work right, or at all, etc. You won't see a v3.0 - > v3.4 update from Ford. The only ones that can update to v3.4 are APIMs that shipped with v3.2 or later.
 




yohanofUM

New Member
Joined
January 11, 2020
Messages
16
Reaction score
0
City, State
Ann Arbor, MI
Year, Model & Trim Level
2017 Explorer Sport
Some enterprising individual
LOL - that's how it all started with the LS swaps... once they had access to the ECM, boom - a whole new lease on life for 20yo engines.

Unless 3.4 will fix my bluetooth problem, I don't see a return in the risk of bricking my APIM.
 
Last edited:




RedDen

Active Member
Joined
March 14, 2012
Messages
491
Reaction score
13
City, State
Calgary
Year, Model & Trim Level
2012 Explorer Limited
Apparently, pretty much anyone (with some knowledge) can upgrade to v3.2, v3.3 or 3.4, what is required is updating APIM with new calibation files.
I found it on russian web (ford focus forum), people doing that and everithing is working just fine:

Apparently, written by non-native english speaker, lot of mistakes...

Ok so, here a short guide: (sorry, it's all english)

What is it:
This is the tool used to flash all packages at the same time at Ford Factory.
This tool is exactly like the previosuly found 1U5T-14G386-BB (found in 2017), even the internal version (v.306) is the same. The only difference is that this one is signed with the certificate used to sign public packages, and that means that it will work on EVERY APIM module out there.

What can one do with it:
You can upgrade APIM MY16 / MY17 to MY18.5 by upgrade the APIM calibration to any MY18.5 version, but remember that this tool is not specifically designed to do that. If you look (well you cannot since you don't have root access lol) at the logs generated by the tool you will see that there is indeed an internal error, (it still detects MY16 / MY17 APIM) but for some reason it skips that error and start the repartitioning using the new table (1.5GB).

How can one upgrade from MY16 / MY17 to MY18.5?
First of all update the APIM calibration (i will not do a guide about that at the moment, maybe later) using Forscan (might be unstable) or UCDS (more stable). BEWARE THAT IF THE UPDATE PROCEDURE FAIL YOUR APIM MIGHT BE UNUSABLE; AS IT'S NOT ALWAYS POSSIBILE TO REVIVE IT

Once you have upgraded the APIM calibration to MY18.5 you have to do that:
1) Prepare a USB key with the 1U5T-14G386-CB package (inside the folder SyncMyRide) and create an autoinstall.lst with that file.
2) Put the USB key in the APIM and wait the installation to finish. (ONCE YOU DO THAT, YOU WILL NO LONGER ABLE TO BOOT THE SYNC 3 OPERATING SYSTEM!!)
3) Reboot the APIM
4) Now you will see the Factory Mode that is asking you to insert a USB Key, so create a new USB Key with that
* SynMyRide folder with the My18.5 package you wanna install
* A file named reformat.lst instead of autoinstall.lst

The internal format for this file must be this:
citation:
APPS=yourPackageName.tar.gz
(DO NOT WRITE SyncMyRide folder in the path like you normally do on autoinstall.lst... write ONLY the package name)

5) Wait the process to terminate
6) Enjoy the 3.2+ version


Just for you interest, the application support every type of packages, so you can flash all of them in a single shot.

The variables you have to use if you want do that are:
citation:
APPS=
VOICE=
VOICE_NAV=
MAP=
GRACENOTES=
It's important to note that this tool it's also usefull to CLEAN / RESET the apim (ANY APIM, MY16 MY17 or MY18.5) in case you got some errors that cannot be fixed by reinstalling the packages.
This is the only tool that will really 100% CLEAN your APIM
 




RedDen

Active Member
Joined
March 14, 2012
Messages
491
Reaction score
13
City, State
Calgary
Year, Model & Trim Level
2012 Explorer Limited
and next post:

Calibration must be updated using Forscan or UCDS. In both case you have to follow a specific order. The order is the following:

GB5T-14G376-AA.vbf (Bootloader) //Mandatory
XXXX-14G374-XX.vbf (Diret Config Configuration) //Mandatory
XXXX-14G375-XX.vbf (ECU Calibration Data) //Mandatory
GB5T-14G379-AA.vbf (ECU Cal-Config #1 AKA Audio Profiles) //Facoltative
XXXX-14G379-XX.vbf (ECU Cal-Config #2 AKA Illumination) //Facoltative

Both 14G379 are not mandatory but i honestly don't know which cars need it and which doesn't.

Where you see XX it's because it changes based on revision (version), bootloader and audio profiles never changes (at least until now)

To determinate if a calibration is for a MY18.5 you have to read the first XXXX, they must have 1U5T or 5U5T (maybe 3U5T and 4U5T too but i'm not sure if they exist)

Also, it's important to keep in mind that file 14G374 is different based on APIM region and Flash Size. here a summary:

XXXX-14G375-A*.vbf 8GB / 16GB EU without NAV
XXXX-14G375-B*.vbf 8GB / 16GB NA without NAV
XXXX-14G375-C*.vbf 8GB / 16GB ROW without NAV
XXXX-14G375-D*.vbf 32GB NA with NAV
XXXX-14G375-E*.vbf 32GB CHINA with NAV
XXXX-14G375-F*.vbf 32GB XX (i think it means ANY region) with NAV (Telenav)
XXXX-14G375-G*.vbf 32GB ROW With NAV (NNG)
XXXX-14G375-H*.vbf 64GB EU with NAV
XXXX-14G375-J*.vbf 32GB TURKEY with NAV
XXXX-14G375-K*.vbf 32GB UAE with NAV (NNG)

Where you can download the files?

From here:
https://www.fordtechservice.dealerconnection.com...uct=IDS

or here:
UCDS Calibration File Download
 




RedDen

Active Member
Joined
March 14, 2012
Messages
491
Reaction score
13
City, State
Calgary
Year, Model & Trim Level
2012 Explorer Limited
One poster reported this:

Tried on my17 - result is successful, I got 3.3 without module calibration.
 








UofMEngineer

Active Member
Joined
July 18, 2019
Messages
247
Reaction score
50
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
*Rubs temples*

Some of that info makes no sense / is just wrong. For one, the voice pack for 19274 needs to be 5U5T-14G391-CK or it's technically incompatible. The difference between -CB and -CE has nothing to do with region, just the version of the NA NAV VOICE package. If you're on v3.2 or v3.3 and just update the one file, then you're in even worse shape from a compatibility standpoint. Sigh.
 




RedDen

Active Member
Joined
March 14, 2012
Messages
491
Reaction score
13
City, State
Calgary
Year, Model & Trim Level
2012 Explorer Limited
*Rubs temples*

Some of that info makes no sense / is just wrong. For one, the voice pack for 19274 needs to be 5U5T-14G391-CK or it's technically incompatible. The difference between -CB and -CE has nothing to do with region, just the version of the NA NAV VOICE package. If you're on v3.2 or v3.3 and just update the one file, then you're in even worse shape from a compatibility standpoint. Sigh.

Makes it sense or not, but having free maps update for vehicles older than MY18 is a great bonus.
I updated my Edge to v3.4 and everything is working great, no any bugs. All the voice commands are working. I only updated to build 19200 though as people reporting that build 19274 is cutting ability to browse a USB drive while driving (unless one changed APIM region code to 5753 in Forscan)
 




Sgt1411

Elite Explorer
Joined
February 22, 2011
Messages
4,323
Reaction score
351
City, State
VanBC/GoodyearAZ
Year, Model & Trim Level
2017 Explorer SPORT
*Rubs temples*

Some of that info makes no sense / is just wrong. For one, the voice pack for 19274 needs to be 5U5T-14G391-CK or it's technically incompatible. The difference between -CB and -CE has nothing to do with region, just the version of the NA NAV VOICE package. If you're on v3.2 or v3.3 and just update the one file, then you're in even worse shape from a compatibility standpoint. Sigh.
As some one who works with the Ford IVT I gotta ask you this question.

Please don't take anything I ask or say as "shooting the messenger" because having someone who has inside knowledge is invaluable for people on' this forum.

I was fortunate enough to serve on the Ford Police Advisory Board from 2006-2014 and met many Ford product and software engineers who were very smart people dedicated to their craft.

But why does Ford struggle so badly with multi media platform rollouts?

Without going into great detail, My Ford Touch almost destroyed Ford's reputation it was so bad. Loyal customers were treated very poorly and the fixes were slow and complicated. The end result was new software builds that removed functionality to free up processor memory in an effort to band aid a poorly engineered system.

SYNC3 came along and this was Ford's opportunity to get back some of those customers that were burned off by poorly executed multimedia software. SYNC3 was better than MFT for sure but it still suffered from functionality issues, no OTA updating until just recently, laggy screen transitions, WiFi connectivity issues, and many more. The FordPass App is so limited in functionality it's embarrassing and many times I just get an error message after attempting FordPass commands.

Just look at the complexity being discussed in this thread where customers are hungry to update their system but cant do it officially because of software and hardware conflicts. The competition has none of these issues.

When you look at U-Connect from Fiat Chrysler and MyLink from GM they suffer from none of these issues and their mobile Apps are robust and fully functional. I use them everyday and I see the comparison repeatedly.

Just look at the release of an all new 2020 Explorer platform but not including a hardware migration path for 2020 owners to get their brand new product up to SYNC4 compatibility. That to me is short sighted and extremely poor planning.

Ford leads in many automotive technology related areas but the multimedia platforms continue to disappoint loyal customers.
 




UofMEngineer

Active Member
Joined
July 18, 2019
Messages
247
Reaction score
50
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
Makes it sense or not, but having free maps update for vehicles older than MY18 is a great bonus.
I updated my Edge to v3.4 and everything is working great, no any bugs. All the voice commands are working. I only updated to build 19200 though as people reporting that build 19274 is cutting ability to browse a USB drive while driving (unless one changed APIM region code to 5753 in Forscan)
It's a difference of working v working as designed, without additional bugs, crash potential, incorrect prompting, wrong items on screen, etc.

As some one who works with the Ford IVT I gotta ask you this question.

Please don't take anything I ask or say as "shooting the messenger" because having someone who has inside knowledge is invaluable for people on' this forum.

I was fortunate enough to serve on the Ford Police Advisory Board from 2006-2014 and met many Ford product and software engineers who were very smart people dedicated to their craft.

But why does Ford struggle so badly with multi media platform rollouts?

Without going into great detail, My Ford Touch almost destroyed Ford's reputation it was so bad. Loyal customers were treated very poorly and the fixes were slow and complicated. The end result was new software builds that removed functionality to free up processor memory in an effort to band aid a poorly engineered system.

SYNC3 came along and this was Ford's opportunity to get back some of those customers that were burned off by poorly executed multimedia software. SYNC3 was better than MFT for sure but it still suffered from functionality issues, no OTA updating until just recently, laggy screen transitions, WiFi connectivity issues, and many more. The FordPass App is so limited in functionality it's embarrassing and many times I just get an error message after attempting FordPass commands.

Just look at the complexity being discussed in this thread where customers are hungry to update their system but cant do it officially because of software and hardware conflicts. The competition has none of these issues.

When you look at U-Connect from Fiat Chrysler and MyLink from GM they suffer from none of these issues and their mobile Apps are robust and fully functional. I use them everyday and I see the comparison repeatedly.

Just look at the release of an all new 2020 Explorer platform but not including a hardware migration path for 2020 owners to get their brand new product up to SYNC4 compatibility. That to me is short sighted and extremely poor planning.

Ford leads in many automotive technology related areas but the multimedia platforms continue to disappoint loyal customers.
No worries. I'm a customer too so don't think I don't hit / get annoyed by several of the same issues everyone else does too. :) MFT is before my time, so I can't really speak much to that one, though most of this is out of my wheelhouse. Some of these are likely just bug related, and some are probably more hitting a hardware limitation at this point. Gen 3 has had quite a bit added to it over the years. There has never really been an official hardware upgrade path for any of the main OEMs and infotainment systems, at least not that I have personally seen. I've heard discussions about it, namely at my prior OEM where I was involved in it, but it was shot down for technical and customer cost reasons.
 




UofMEngineer

Active Member
Joined
July 18, 2019
Messages
247
Reaction score
50
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
Also, just for reference...Generally (there can be an exception here or there, -FL instead of -FK for example), the pairings are:

3.4.19101 --> 5U5T-14G391-xE
3.4.19200 --> 5U5T-14G391-xH
3.4.19274 --> 5U5T-14G391-xK
 








RedDen

Active Member
Joined
March 14, 2012
Messages
491
Reaction score
13
City, State
Calgary
Year, Model & Trim Level
2012 Explorer Limited
Which one can we use to upgrade from an explorer 2017 with SYNC 3.0 Build 19205??... Thx
skip step one with APIM firmware update and start with step two, make two usb drives, second one preferred to be USB v3.
 




peterk9

Staff member
Moderator
Elite Explorer
Joined
December 28, 2010
Messages
28,423
Reaction score
1,741
City, State
Russell, Ontario (Ottawa area)
Year, Model & Trim Level
2020 Aviator Reserve
Callsign
VE3
Which one can we use to upgrade from an explorer 2017 with SYNC 3.0 Build 19205??... Thx
Welcome to the Forum Kyle.:wave:
Just remember what the Ford employee working on Sync 3 mentioned. That the upgrade is not intended for the Explorer and certain features may not work as intended.
Personally, I would wait for the official upgrade to avoid possible issues.

Peter
 




UofMEngineer

Active Member
Joined
July 18, 2019
Messages
247
Reaction score
50
City, State
Michigan
Year, Model & Trim Level
20' Escape Hyb Titanium
Personally, I would wait for the official upgrade to avoid possible issues.
Peter
In this case of v3.0, there will never be an official update as v3.4 is not meant to run on the older modules. If you tried to load it without changing the partition, you'd brick the APIM. I imagine when he v3.2/v3.3 -> v3.4 update becomes available, then a more matched set of files would become available, as those usually all appear online pretty quickly.
 


Join the Elite Explorers for $20 per year. Gets rid of the ads! New $5 per month "try out" option.

Explorer Forum has probably saved you that much already, and will continue to save you money as you learn how to diagnose fix problems yourself and learn which modifications work without having to experiment on your own. Elite Explorer members see no advertisements, no banner ads, no double underlined links, can add their own profile photo, upload photo attachments in all forums, and Media Gallery, create and save more private Conversations, and more. Join Today. Your support is greatly appreciated.




LakeRatTX

New Member
Joined
January 11, 2020
Messages
4
Reaction score
1
City, State
Austin, TX
Year, Model & Trim Level
2018 Explorer Platinum
I am extremely frustrated with Ford right now.

My 2018 Explorer NA with Nav is on build 17276. Checking for updates on the Sync unit or owner.ford.com both tell me that I'm up to date. I ended up calling Ford to find out why the updates don't show up for me. I got passed around from customer service, to the FordPass people, and then to In Vehicle Technologies. They all said the same thing, that Sync 3, software version: 3.0 is the latest update for my system. None of them had ever heard of the term "build number". The IVT woman said she had checked Oasis, and that there were no updates available. All of the support people that I talked to said I need to bring the vehicle to the dealer so they can check for the update.

There is no love lost between me and the dealers in my area. Most of them hold the vehicle for days, for even the most minor problem. Even when I get the vehicle back, the problems are rarely fixed. If all they are going to do is check Oasis, they are probably just going to tell me that there is no update available.

I wouldn't care about the update if it didn't fix a problem that I am having. Waze consistently shows my speed 10 to 15% higher than the speedometer does, when connected via Apple Car Play. This known issue was fixed in 19205, if I can ever get it.

Has anyone found a way to get Ford to send the 19205 update to my vehicle account?
 




Top