• Register Today It's free! This box and some ads will disappear once registered!

  • Holiday Special! - 2 for 1 Elite Explorer sale!

    Right now you can purchase an Elite Explorer membership for $20 and receive a two year membership!

    Click Here to start your membership and get rid of the ads!

No Heat Passenger Side


pzy3339

Active Member
Joined
November 29, 2012
Messages
244
Reaction score
1
City, State
columbus ohio
Year, Model & Trim Level
2006, 4x4 Limited 4.6
HVAC issue here.

Can someone describe how this system operates for me please.

I have dual zone climate control, the passenger side does not get any heat.

Do I need to look for a coolant flow regulator, or a blend door actuator? What could prevent the passenger zone from getting heat?

I am assuming there is 1 heat exchanger and two blend doors with individual actuators.

Thanks
 












dantheman68

New Member
Joined
November 2, 2015
Messages
19
Reaction score
0
City, State
Milwaikee, WI
Year, Model & Trim Level
2007 Explorer Limted
x2 blend door.

You can run the EATC check, get the Truck up to temp and have the EATC off, then press the off button and front defrost at the same time and then and immedately press the automatic button. The system will test and then display a code, otherwise the entire display will light up. Just another way to troubleshoot to try and be sure.

Mine had the same symptoms, and the EATC check showed all good, I replaced the blend door actuator anyway and its been good for over a year now.
 




Top